Columns with span columns CS5

In a 2 column layout in CS5, how would I know if text is in first or second column, when there are span columns text which add to the column count

Hi
I tried to do with this code.
if (app.selection.length === 1 && app.selection[0].hasOwnProperty('baseline')) {
     var sel = app.selection[0];
     alert(which_column(sel));
function which_column(sel){       
     var sel_indx = sel.texts[0].index;
     var parent_tx_column = sel.parentTextFrames[0].textColumns;
     var columns_count = sel.parentTextFrames[0].textFramePreferences.textColumnCount;
     for (var i=0, iL=parent_tx_column.length; i < iL ; i++) {
          if (sel_indx < parent_tx_column[i].characters[-1].index){
               var is_span_column = sel.spanColumnType === SpanColumnTypeOptions.SPAN_COLUMNS ? " (SpanColumn)" : "";
               var result = "in Column No."+(i+1)+is_span_column;
               return result
This snippet returns like below
1. 1st column and isSpanColumn
2. 2nd column
cont...
thankyou
mg.

Similar Messages

  • Problem with MathType and CS5 due to InDesign

    We publish Math and Science curriculum and we run into the problem below.
    the second bullets is imported wrong in CS5. Is there a work around? (I also emailed Design Science). We'd rather use CS5 since all our other subjects are done in CS5 and we want to be able to use spanning across columns which does not exist in CS4.
    The same happens when using MT Extra instead of Euclid Extra.

    BTW, Jongware, I was a bit unfair about the fonts. You can sign up for the 30-day free trial of Mathtype and then you get the fonts. Furthermore, the strong implication is that you need not delete them after the trial period is over, and therefore you also can extract them from the installer for use like this with no compunctions (which is what I did). Source: MathType: Font Installers.
    redesign: Moving right along, just like Jongware, when I open your CS4 document in CS4, I see the same behavior Jongware saw and the same behavior you saw in CS5 (which I also see in CS5), namely the goofy circle glyph (seems to be GID 64 and U+F069):
    I did have to turn on high-resolution previews, though otherwise I got something else entirely.
    I notice, however, that you seem to have authored this file using some 3rd party plugins:
    Since that seems to be a math-related plugin, it doesn't seem inconceivable that it is part of the issue.
    I suggest you disable it and re-test in CS4.
    The font does seem a bit goofy...The goofy circle glyph appears in FontForge, as a ccwcontourcircle, but not in
    standard Mac font apps, like TextEdit. It's also the 'i' position in the font.
    I don't know enough about fonts to dig and really figure out why you get one character when it is first and another when it is second, but I really don't think this is InDesign. Oh, right, let's look at the EPS file in another program...
    Curiously, Preview.app indeed shows the bullet glyph in the first position (and in the second).
    Adobe Illustrator, which I opened by accident (ha!), shows ccwcontourcircles.
    So it seems that Apple and Adobe's EPS renderers treat this font differently.
    I suppose it might be an Adobe bug, but I'm more inclined to suspect its ambiguous... The way the ccwcontourcircle is encoded seems strange to me.
    Well, I think that's enough for me. Basically, Jongware and I see consistent behavior with CS4 and CS5 — oh, actually. Are you using CS4 and CS5 on the same machine? Or on different machines? Because...I suspect this is handled by the AGM library, and it may well be that using CS4 on a machine with CS5 makes it use CS5's AGM library. But that might not be true at all, just speculation.
    Anyhow, I'm not sure what Jongware's newfound Adobe Support optimism is based on. I suspect you'll hear from Design Science in the next day or two, and maybe from Adobe by September. But perhaps I am too pessimistic on Adobe Support right now.
    I suppose making it consistently ccwcountour doesn't help you overmuch though. Hrmm.

  • What software for someone to help with Premiere Pro CS5

    For the last 9 months I have been processing video using PP CS5 for a small church.  The church is now recording several programs and I would like some help in processing the videos that are created.  The church is small so probably can't afford a copy of the software that I have, so I will have to propose some options for them.  The two that come to my mind are:
    1) Adobe allows me to have two machines loaded with Master Collection CS5.  Since I am only using one, I could install on another person's computer.  I think this may be somewhere less than the spirit of the EULA.  Besides, I am not real anxious to do this anyway.
    2) Help them find a low cost alternative.  I think they may be able to do this for $100 to $200 for the software.  All they need to do is to trim the ends of the extra film, then add some title slides and save to Flash for the website and burn to DVD for archive.  As an option, they might be able to make a menu for the archive DVD.
    Anybody know of any other options or suggested low end video editing software.  BTW, I took a quick look at Cyberlink PowerDirector and I could not find a way to save in the Flash format - other than creating a Youtube account and then sending the video directly to Youtube.

    Colin,
    You are correct. PrE will handle AVCHD on an adequate computer. It will edit, allow Titles, PiP, many Effects (too many are Auto only, however), and can Export/Share to Flash, with one big caveat - there is NO Transparency available from PrE, like from PrPro, so no sprites, etc. Just plain FLV.
    The files that PrE works from will work in PrPro and vice versa. However, the use of a PrPro PRPROJ (Project file) will NOT work in PrE. A PrE PREL (Project file) might Open in PrPro, but there are a bunch of things that can keep this from working correctly: Themes/Instant Movies, some New Blue FX Effects and Transitions, etc., that are specific to PrE. Otherwise, if PrE and PrPro are contemporary, say PrE 9 and PrPro CS5, and not of that "stuff" is used, it is likely that a PrE 9 PREL will Open in PrPro CS5 - I can do that with PrE 4 and PrPro 2.0/CS2, as they were contemporaries. I cannot Open later PrE PREL's in PrPro 2.0/CS2, and only get a failure.
    For simple editing (especially if one is not intending on migrating between PrE & PrPro), PrE should fit the bill nicely. Much more is done "behind the scenes," and the GUI is more of a "Big-Button" solution, than PrPro, where one has much more control, though much needs to be done by hand. There are also some MAJOR layout differences between the two GUI's, but with some training, one can go with either pretty easily.
    Hope that this helps,
    Hunt

  • Adobe Audition CS5.5 with Premiere Pro CS5

    Hello everybody.
    I am considering downgrading from Master Collection CS5 to Adobe Production Premium CS5.5
    But quite frankly it's just because of one application.
    Though, i am in doubt if i'll actually going to make the downgrade.
    And as you could and might have guessed it is the Adobe Audition CS5.5 Application.
    Though really the whole pack has a GREAT improvement overall, I just actaully want to mix SEAMLESSLY with Premiere Pro and sound editing application (Audition).
    Which leads me to my next question.
    Now with Adobe Soundbooth CS5 closed off (by April 24th), and an UPGRADE for Soundbooth CS5 users to Audition CS5. Does this mean that Audition CS5.5 works SEAMLESSLY with Premiere Pro CS5?
    Is there a dynamic link between the two applications? (Audition CS5.5 and Premiere Pro CS5)
    AM i able to send mixes between the two? I really don't want to loose any Audio data, such as 5.1 channel mapping, volume mixing, denoising, general mixing etc.
    All i really need is some good quality sound editing which works seamless, as After Effects and Premiere Pro has proved to me can be done.
    Just want to know if it is possible. Or if I REALLY have to upgrade in order to get the sweet apples.
    Best
    Lucas

    Hi _durin_
    Thanks for your quick response.
    But I didn't quite understand your answer.
    I have seen Jason Levine's video earlier, as CS5.5 was announced and it looks natively good. I understand the mixdown attributes etc.
    Please correct me if im wrong HOWEVER this workflow and settings applies still to ONLY the new CS5.5 Version?
    Im currently using Master Collection CS5.
    Instead of getting either the Production Premium, or Master Collection I am strongly considering updating Soundbooth CS5 to Audition CS5.5 (the option is there as i can tell by SoundBooth's website, though i get a weird error message when I click the update link...)
    However I need to know, IF Audition CS5.5 works well with the PREVIOUS version (that'll be CS5 not 5.5), of Premiere Pro.
    Are there an option to render the reference video, and generate a interchange session from WITHIN Premiere Pro CS5 to Audition CS5.5?
    Im sorry if I either sound harsh or "willingly" misunderstanding. But I have only documentation on how the integration works between the current versions (meaning 5.5).
    Im as you can guess VERY confused over the move from Adobe to make a .5 version instead of a full-fledged CS6 solution. It causes a stir, cause I then don't know much of the integration between the previous applications.
    I have seen as an example that Photoshop CS5 have gotten the update to receive paintings/files made with their new touch API. So I wonder whether integrational features will be a part of the CS5 pack since, as i've mentioned, an application like Soundbooth gets replaced with Audition, with an upgrade option for the Soundbooth owners.
    Im confused and hope you can help me clear my mind up, whether to upgrade or not. I will download the trial eventually, but not onto my current CS5 system since I already use this in my daily video work and want to AVOID confusion.
    Best
    Lucas

  • I could not open my camera raw files from canon mark iii with my photoshop CS5. Tried to update Camera raw 6.7 but failed to install. Message said 'There was an error downloading this update. Please quit and try again later'. How could I open Raw files ?

    I could not open my camera raw files from canon mark iii with my photoshop CS5. Tried to update Camera raw 6.7 but failed to install. Message said 'There was an error downloading this update. Please quit and try again later'. How could I open Raw files ?

    Try installing it manually from:
    Adobe - Adobe Camera Raw and DNG Converter : For Windows : Camera Raw 6.7.1 Update
    Adobe - Adobe Camera Raw and DNG Converter : For Macintosh : Camera Raw 6.7.1 Update
    Regards,
    Ashutosh

  • Raw files from the new Nikon D810 will not open with either Photoshop CS5.1 or Lightroom 4.  When will a real Adobe solution be available to work with Raw (NEF) files in their native format, using CS5.1 and LR4?

    Raw files from the new Nikon D810 will not open with either Photoshop CS5.1 or Lightroom 4.  When will a real Adobe solution be available to work with Raw (NEF) files in their native format, using CS5.1 and LR4?

    Clarification: this is a user forum; you are not addressing Adobe here.
    The answer to your question as phrased is: never.
    CS5 is history and it is not longer supported.  There will not be any updates or bug fixes for CS5.
    You need to convert the raw NEF files from your D810 to raw DNGs using the free, standalone Adobe DNG Converter 8.6 RC (beta), the first version ever to support that camera.. 

  • Premiere CS4 with Media Encoder CS5?

    Hi,
    When I was given my CS4 suite (production premium) years back, it included Premire Pro.  Then, when I told my boss I needed to upgrade to CS5, he purchased the Web Premium Suite.  This was fine, for the most part, as Illustrator, Flash, and Photoshop are the main programs I use, but we just recently got a video project that is giving me some issues.
    We created what turned out being a 4 min + video.  After some trial and error we settled on creating multiple segments in Flash and exporting them as uncompressed MOV files from Flash.  Then we brought all of those MOV files together in a premiere pro project.  The problem seems to occur when I export out an MP4 video from Premire Pro CS4.  Premiere launches Media Encoder CS4 and then creates the MP4.  The MP4 plays on a cellular device like we want it to, but it will not display a thumbnail/preview of the video when viewing the video in the phones gallery.
    We have tried some other tests, and if we export out an MOV or AVI from Flash CS5 then convert that to an MP4 using Media Encoder CS5, there suddenly seems to be a thumbnail on the phone for the video.  After multiple tests, it appears the problem might be related to which version of Media Encoder our final MP4 is produced in.  ME CS4 - No thumbnail. ME CS5 - thumbnail.
    The problem is, we HAVE to use Premiere as our final compiling tool, but I cant seem to get a Premiere Pro CS4 file to work with Media Encoder CS5.
    Any thoughts???
    Thanks,
    Justin

    but to automatically open up AME CS5 ... hmmm.. maybe a hack?
    No, that will not work. Even if you have Audition 4.0 installed (beta), edit in Audition from CS5 will only access Audition 3.0.
    The only way to try it is to open AME CS5, go to File/Add Premiere Pro Sequence and select the CS4 project and then the correct sequence.

  • How can I reduce (or remove) camera shakes in a video with Premiere Pro CS5???

    I want to reduce (or remove) camera shakes in a video with Premiere Pro CS5. Is there an build-in plugin I can use, or do I have to  download / buy one? Thanks.

    You didnt need to look very far down the page to see this...
    http://forums.adobe.com/thread/619165?tstart=0

  • Something is up with brsuh on cs5 photoshop for me.

    Hi everyone. I have a little problem with brushes on cs5 photoshop...
    The problem is that if brush is big I can't see half of the brush, but if it's small like 50px I can see it all.
    Maybe someone knows how to fix this problem so I could see the brush normaly.
    Ty for your help.

    Update your graphics card driver and/or disable openGL drawing in the prefs.
    Mylenium

  • Need info about nvidia graphics card supported with premiere pro cs5

    Hi
    I need information about nvidia graphics card supported with premiere pro cs5
    If I have a computer(portable) with this video card or graphics card :
    nVIDIA® GeForce™ GTX  285M with 1GB DDR3 Video Memory available in Single or Dual (SLi) Configurations
    Microsoft® DirectX® 10 Compatible
    is it going to support MPE in premiere  pro cs5?
    Regards,
    Vinay

    To be clear:
    You asked about supported cards. Here is a list of supported cards. Others on this thread are telling you how to make an unsupported card function to some degree using a method that is not advocated by Adobe.

  • Issue with Adobe Encore CS5.1 and Matrox MAX H.264 encoding on Windows

    Here's some information on an issue that we've identified with Matrox products and Encore CS5.1:
    "Issue with Adobe Encore CS5.1 and Matrox MAX H.264 encoding on Windows"

    Still flickering on Encore even when rendered in MPEG-2 DVD in Pemiere Pro CS5.5. Looks perfect in Premiere Pro.
    Any other ideas?
    EDIT: Was looking for Google for people with similar problems to me and I came across this http://forums.adobe.com/message/3959757?tstart=0
    I am currently re-rendering the video in PAL DV Widescreen MPEG-2 DVD and using maximum render quality.

  • Are there any issues with Adobe Photoshop CS5 and OS X Yosemite 10.10?

    Are there any known issues with Adobe Photoshop CS5 and OS X Yosemite 10.10? I heard I would need an older Java version to start it.
    [ spammy links removed by admin ]

    You'll need to reinstall Photoshop CS5 after installing the MacOS 10.10 update -- for some reason the OS updater stomps on some of the Photoshop files.

  • Use Premiere pro cs5.0 with media encoder cs5.5

    Is it possible to use media encoder cs5.5 together with premiere pro cs5.0?

    I have read that each version of Premiere Pro is a distince install, into a separate folder
    So, you may have CS5 and CS5.5 installed at the same time, and neither one gets in the way of the other
    As far as I know, that means that CS5 will ONLY look for and use the products installed in the CS5 area
    So, no, I do not think any part of CS5 will work with any part of CS5.5

  • Timecode video sync with spanned clip problem for multicam edit

    I wasn't being able to sync 3 camera angles from a recent shoot with 3 EX3's all synced using the clock on one camera as master and free run on the other two cameras as slaves. External link came up on the displays and the videos show in premiere to all have the correct embedded timecode.
    Yet, the synchronize menu via timecode doesn't work.
    I found that it must be a problem with spanned clips but I can't figure out how to get around this problem. I'm able to synchronize these clips in final cut pro 6.0.6 but not in premiere cs 5.5 or cs 4.2.
    Anybody ever have this problem or any suggestions?

    Hi Jonathan,
    It's not always so easy to do NTSC <-> PAL conversions, and it's impossible to do them in Premiere while maintaining any degree of quality.
    You can do a good job of this with AviSynth (freeware) but the learning curve may be a bit steep for a newbie. I also hear that ProCoder ($500+) does a good job of this but I've never tried it.
    As for the sync, you can chop up your PAL clip within the muticam sequence (leaving some "holes") and match up particular points manually. You'll obviously have to edit around the holes.

  • Does the new version of lightroom work with an old CS5 photoshop?

    Does the new version of Lightroom work with an old CS5 photoshop?

    Yes - they will work together.
    However, the Camera Raw versions will not match - meaning you may have to render your file into a tiff to bake-in your LR Settings before passing the file to PS CS5,

  • Sg-300 - 3750 stack with SPANNING-TREE root problem.

    Morning. I think ive configured a few hundred switches, maybe a thousand in my time, but never have a faced such horribleness that is the SG-300. After this week, I think ill refuse to touch them.
    Got 2 voice vlans and running a few vrf's on a 3750 stack. but this discussion is about layer 2.
    2 x 3750 stacked
    1 x voice switch sg-300 company A voice vlan 18 - Po1 up to 3750 distributed etherchannel Po1 (LACP active both sides) 2 ports in channel
    1 x voice switch sg-300 company B voice vlan 19 - Po1 up to 3750 distributed etherchannel Po2 (LACP active both sides) 2 ports in channel
    Allowed vlans on both sides (command on Port-channel) are data A, Voice A, Mgt A to switch A
    Allowed vlans on both sides (command on Port-channel) are data B, Voice B, Mgt B to switch B
    It seems that these switches are limited to one voice vlan....
    and that spanning tree BPDU's are ignored (or not recevied- havnt released the shark yet).  let me explain.
    originally when using "smart port" the switch with the lowest mac address, whatever Voice vlan was configured would take over the other switche's voice vlan, argh what a nightmare.
    I gave up on the GUI as its far to complcated and have Almost got this working.
    I am now using auto voice vlan, but have disabled smart macro. I hope that disabling smart macro stop other switches from learning the switch with the lowest mac address's voice vlan.  So far so good - in the LAB. No where was it documented in the cli guide how do disable this stupid feature.
    DHCP is working from scope on core, can mange the switches etc etc, access vlan voice vlan all good (after a monster battle).
    Now I have an issue with spanning tree.
    spanning tree priority for vlans 1-4094 on the 3750 is 4096.
    spanning tree priority for vlans 1-4094 on the SG-300's is 6xxxx.
    ALL switches think that they are the root. (well the "logical" 3 of them) The 3750's for all vlans, and the SG-300 for the one instance as it doesnt support per vlan.  (I am not interested in trying MST here..this is not a datacentre)
    On the 3750's Ive tried ieee, pvst, rpvst, while matching the non per-vlan equivalent on the SG series.
    What is the difference between a General port and Trunk Port on a SG-300 specific to spanning tree, native vlans (when you can just configure an untagged vlan anyway!!) and what is the relevance to the way the bpdu's are carried?
    And why the need for a PVID, when you can tell a port what is tagged and what isnt.
    Does the trunk need Vlan1 to be explicitly allowed, and untagged? Does the Po trunk need to be a general port with PVID configured? in vlan 1?
    I need to sort this, as cannot put an access switch into production that thinks it is the root of the tree.  I wish I had a 2960.... a 3500XL..anything
    Does anyone have CLI commands that can help here?

    F.Y.I for catylyst heroes - here is the equivalent config for SG-300 - Vlan1 is required on the allowed list on the catylyst side (3xxx/4xxx/6xxx)
    In this example:
    VLANS - Voice on 188, data on 57, management on 56.
    conf t
    hostname XXX-VOICE-SWXX
    no passwords complexity enable
    username xxxx priv 15 password XXXXX
    enable password xxxxxx
    ip ssh server
    ip telnet server
    crypto key generate rsa
    macro auto disabled
    voice vlan state auto-enabled !(otherwise one switch controls your voice vlan….)
    vlan 56,57,188
    voice vlan id 188
    int vlan 56
    ip address 10.230.56.12 255.255.255.0
    int vlan1
    no ip add dhcp
    ip default-gateway 10.230.56.1
    interface range GE1 - 2
    switchport mode trunk
    channel-group 1 mode auto
    int range fa1 - 24
    switchport mode trunk
    switchport trunk allowed vlan add 188
    switchport trunk native vlan 57
    qos advanced
    qos advanced ports-trusted
    exit
    int Po1
    switchport trunk allowed vlan add 56,57,188
    switchport trunk native vlan 1
    do sh interfaces switchport po1
    !CATYLYST SIDE
    !Must Explicitly allow VLan1, this is not normal for catalysts - or spanning tree will not work ! Even though it’s the native vlan on both sides.
    interface Port-channel1
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,56,57,189
    switchport mode trunk

Maybe you are looking for

  • Suggestion for a new lenovo laptop

    sir ,      I live in Patna , Bihar . I want to buy a new lenovo laptop ranging under 35000 rupees. my requirments are as followes 500 GB  hard disk 4 GB RAM i3 4th generation processor DOS / windows but preferably DOS screen size 15.6'' strong and co

  • Error message when downloading flash?

    I am trying to download flash but every time I try the installation is stopped by an error message telling me that a more current software version is needed. I go to the directed site to get the more current version but get the same version and the s

  • Wintergame does not work with 10.8 and no assistence from apple or the seller

    I have bought in the official Apple Ap Store the game Wintergames. But it does not work with mit OSX 10.8.3 Every i try to load this programm it brakes down. I have contacted the seller. He is not interested in the problem and gave only the hint to r

  • ALV - Buttons handling

    Hi gurus, My ALV(reuse_alv) report has 4 buttons(custom buttons, like category wise view, plant wise view etc) created by me and iam using my own GUI status. Now when i view my report and navigate between the four buttons the functionality is not wor

  • Batch No Tracking

    Hi Friend     My clint having texturising machine.while he buy the raw material they got a merge number(batch number).when they get a production order they use raw material for single batch number they never mix two (mergh)batch number. based on raw