Dynamically define target address for logical ports (NW'04)

Hello,
when developing a web-service client using standalone proxy, you have to define the target address of a Web Service in the property-page for the Logical Port.
We have the following problem. If, for any reason, the URL of the Web Service changes (i.e. the hostname or the port),  we have to rebuild the whole project and then redeploy the project.
Is there a way to change this URL dynamically by java-code?
Thanks in advance,
Jarle

Hi,
You can get Server name Dynamically. You follow the below steps.
1. Create a HTTP Destination in visual administrator which stores the server name and port.
2. Access this variable in your controller init method and build your web service url with server name and port and use _setEndPoint() method
String prefixURL = "http://";
// your Service Address...remove the first part from service url.
String serviceURL = "/TestService/Config1?style=document";
DestinationService dstService = (DestinationService) obj;
Destination destination = dstService.getDestination("HTTP","ApplicationServer");
Properties destprop = destination.getDestinationProperties();
HTTPDestination httpDestination = (HTTPDestination) destination;
String serverName = httpDestination.getUrl();
prefixURL = prefixURL + serverName;
String testURL = prefixURL + serviceURL;
Request<Obj> testReq = new Request<Obj>();
testReq._setEndPoint(testURL);
You need to import below files into your project.
import com.sap.security.core.server.destinations.api.Destination;
import com.sap.security.core.server.destinations.api.DestinationService;
import com.sap.security.core.server.destinations.api.HTTPDestination;
import java.net.HttpURLConnection;
import java.util.Properties
hope it solved your problem.
Regards,
Sridhar

Similar Messages

  • How to find MAC address for WAN port for Airport Express 2nd Gen.

    The New Airport Express has a LAN and a WAN ethernet ports. How can I find the MAC address for the WAN ethernet port as my Service Provider needs it for provisioning....I can fid MAC address for Ethernet and for two wireless 2.4 & 5GHz but not for WAN ethernet port using Airport Utility 6.1

    Many thanks for the swift response. However, there is no WAN MAC address on the box or on the device anywhere. I even used magnifying glass to find one .
    The airport utility shows only three mac addresses. One for 2.4GHz, one for 5GHz and one fo the ethernet (LAN port) whereas there is another ethernet port in the device mentioned as WAN port and I am still not able to find the MAC address for the WAN ehternet port for Airport Express (2nd Generation).
    Will appreciate a response to make th device work wiht my service provider as providing them the WAN mac address is a must. Had there been an option for cloning mac address, the issue would have not been there.
    Many thanks again - in advance.

  • Test RFC connection for Logical port

    Hi,
    I've created a new Proxy class in my development by consuming the WSDL file and attached it to a package.
    Also i have created Logical port based on the WSDL file in SOAMANAGER. But when I test the RFC connection which gets automatically created
    I get message u2018Create failed: Argument not foundu2019, If any one has experienced this problem please guide me.
    Thanks,
    Ganesh

    Hi Bhaskar
    Kindly refer the SAP Note with RFC error
    1906868 - Transaction program not registered error happened during connection test of Java Idoc adapter
    1989478 - IDoc_AAE 'Program XI_IDOC_DEFAULT_PID not registered'
    Regards
    Sriram

  • Define constant ip addresses for wired ports

    Hi,
    I am using WRT54GL. I got 3 computers and one shared printer - all connected wired to port 1-4 in the router.
    i also got 2 wireless leptops which work fine with the router.
    my problem is that every time i got problems with the elctracity (which turns off the power from the router) the wired computers and the printer got diffrent ip address (which makes alot of work to configure everything in the softwares again).
    how can i set the port manually so i will get address 192.168.1.101 for port 1, 192.168.1.102 for port 2 and co...
    thanks in advance,
    Itay
    Solved!
    Go to Solution.

    Windows IP Configuration
       Host Name . . . . . . . . . . . . : IB-Notebook
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
    Ethernet adapter Bluetooth Network Connection:
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
       Physical Address. . . . . . . . . : 00-1A-6B-DF-83-45
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
    Wireless LAN adapter Wireless Network Connection:
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Intel(R) PRO/Wireless 3945ABG Network Con
    nection
       Physical Address. . . . . . . . . : 00-1B-77-C0-AB-0E
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::64a1:fcbd:3719:19ba%12(Preferred)
       Autoconfiguration IPv4 Address. . : 169.254.25.186(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.0.0
       Default Gateway . . . . . . . . . :
       DHCPv6 IAID . . . . . . . . . . . : 218110839
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-13-1E-FE-2B-00-1B-24-8F-F2-79
       DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                           fec0:0:0:ffff::2%1
                                           fec0:0:0:ffff::3%1
       NetBIOS over Tcpip. . . . . . . . : Enabled
    Ethernet adapter Local Area Connection:
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Realtek RTL8101E Family PCI-E Fast Ethern
    et NIC (NDIS 6.20)
       Physical Address. . . . . . . . . : 00-1B-24-8F-F2-79
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::4910:760b:7363:ce99%11(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.1.102(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : יום ראשון 07 מרץ 2010 00:24:20
       Lease Expires . . . . . . . . . . : יום שני 08 מרץ 2010 13:15:01
       Default Gateway . . . . . . . . . : 192.168.1.1
       DHCP Server . . . . . . . . . . . : 192.168.1.1
       DHCPv6 IAID . . . . . . . . . . . : 234887972
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-13-1E-FE-2B-00-1B-24-8F-F2-79
       DNS Servers . . . . . . . . . . . : 132.72.140.46
                                           212.143.212.143
       NetBIOS over Tcpip. . . . . . . . : Enabled
    Ethernet adapter VMware Network Adapter VMnet1:
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet
    1
       Physical Address. . . . . . . . . : 00-50-56-C0-00-01
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::38ca:a58e:1770:301a%16(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.25.1(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . :
       DHCPv6 IAID . . . . . . . . . . . : 604000342
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-13-1E-FE-2B-00-1B-24-8F-F2-79
       DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                           fec0:0:0:ffff::2%1
                                           fec0:0:0:ffff::3%1
       NetBIOS over Tcpip. . . . . . . . : Enabled
    Ethernet adapter VMware Network Adapter VMnet8:
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet
    8
       Physical Address. . . . . . . . . : 00-50-56-C0-00-08
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::e14a:775e:6f09:3671%17(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.16.1(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . :
       DHCPv6 IAID . . . . . . . . . . . : 620777558
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-13-1E-FE-2B-00-1B-24-8F-F2-79
       DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                           fec0:0:0:ffff::2%1
                                           fec0:0:0:ffff::3%1
       NetBIOS over Tcpip. . . . . . . . : Enabled
    Tunnel adapter isatap.{D2B518A4-E21C-4E01-B434-80AAF2559710}:
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
    Tunnel adapter isatap.{BEC0399E-731D-48E9-8A2B-CA8B8B15BA4D}:
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
    Tunnel adapter isatap.{AFCB73A3-C595-48FD-8E84-9C2FD09C6267}:
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
    Tunnel adapter Teredo Tunneling Pseudo-Interface:
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
    Tunnel adapter isatap.{785CCA76-47EB-4157-BB66-A396AC292746}:
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #4
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
    Tunnel adapter isatap.{9C38D982-ECEA-40E9-A6F0-80396D18316B}:
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #5
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

  • Source address for FXS port

    My confusion is about the source address that voice packets assume for a FXS port in a Ciso router.
    I am pasting relevant configuration from 2 routers below.
    For the 1st router I have the session targets in the dial peer config as the loopback addresses but the QoS is working using a access-list where the source address is the serial ip.
    While in the other router I am getting no packet matches for either the loopback ip or the serial ip.
    ROUTER 1
    class-map shell_voip
    match access-group 170
    policy-map shell_voip
    class shell_voip
    priority 64
    class class-default
    fair-queue
    random-detect
    interface Loopback0
    ip address 10.66.12.25 255.255.255.255
    interface Multilink101
    mtu 100
    bandwidth 1544
    ip address 10.66.50.14 255.255.255.252
    no ip mroute-cache
    load-interval 30
    service-policy output shell_voip
    no cdp enable
    ppp multilink
    ppp multilink fragment-delay 20
    ppp multilink interleave
    multilink-group 101
    access-list 170 permit udp host 10.66.50.14 range 16000 35000 any range 16000 35000
    access-list 170 permit tcp any eq 1720 any
    access-list 170 permit tcp any any eq 1720
    voice-port 2/0
    cptone IN
    voice-port 2/1
    input gain -6
    cptone IN
    dial-peer voice 1 pots
    destination-pattern 40
    port 2/0
    dial-peer voice 100 voip
    destination-pattern 10
    session target ipv4:10.129.67.105
    dial-peer voice 2 pots
    destination-pattern 99
    port 2/1
    dial-peer voice 102 voip
    destination-pattern 11
    session target ipv4:10.129.67.105
    ROUTER 2
    no voice hpi capture buffer
    no voice hpi capture destination
    class-map match-all Vsp_voice
    match access-group 160
    policy-map Vsp_voip
    class Vsp_voice
    priority 32
    class class-default
    fair-queue
    random-detect
    interface Loopback0
    ip address 10.65.10.121 255.255.255.248
    interface Multilink60
    ip address 10.65.50.246 255.255.255.252
    service-policy output Vsp_voip
    load-interval 30
    no cdp enable
    ppp multilink
    ppp multilink fragment delay 10
    ppp multilink interleave
    ppp multilink group 60
    access-list 160 permit udp host 10.65.50.246 range 16000 35000 any range 16000 35000
    access-list 160 permit tcp any eq 1720 any
    access-list 160 permit tcp any any eq 1720
    voice-port 2/0
    cptone IN
    voice-port 2/1
    cptone IN
    dial-peer cor custom
    dial-peer voice 9 pots
    destination-pattern 1101
    port 2/0
    dial-peer voice 10 pots
    destination-pattern 1102
    port 2/1
    dial-peer voice 5 voip
    destination-pattern 8901
    session target ipv4:10.196.3.57
    dial-peer voice 6 voip
    destination-pattern 8902
    session target ipv4:10.196.3.57

    You may want to refer to the following link.
    http://www.cisco.com/en/US/products/sw/iosswrel/ps1834/products_feature_guide09186a0080080115.html
    Your dial peers are using H.323, your source will be what ever interface is used to exit the router as determined by the routing table.
    You could also use a debug IP packet to have a look at your source and destination if you are unsure.
    For this case you may want to just apply:
    h323-gateway voip bind srcaddr 10.66.12.25 on Router 1 and h323-gateway voip bind srcaddr 10.65.10.121 to Router 2. Rememeber to put them under the loopback interface.

  • User defined Selection screen for Logical database

    hi all,
           can we display a user defined selection screen instead of the default selection screen in LDB . eg pnp
    cheers
    senthil

    Hi,
    to my knowledge, the selection screen of a logical database can only be changed (versions!) in the logical database itself.
    What you can do is, write a program with your own selection screen an then either call another program that uses the LDB or -  much better - you call the LDB from your program with function module LDB_PROCESS!
    Example taken from the example library (TA ABAPDOCU):
    <b>REPORT demo_logical_database.
    DATA wa_spfli TYPE spfli.
    SELECT-OPTIONS s_carr FOR wa_spfli-carrid.
    DATA: callback TYPE TABLE OF ldbcb,
          callback_wa LIKE LINE OF callback.
    DATA: seltab TYPE TABLE OF rsparams,
          seltab_wa LIKE LINE OF seltab.
    callback_wa-ldbnode     = 'SPFLI'.
    callback_wa-get         = 'X'.
    callback_wa-get_late    = 'X'.
    callback_wa-cb_prog     = sy-repid.
    callback_wa-cb_form     = 'CALLBACK_SPFLI'.
    APPEND callback_wa TO callback.
    CLEAR callback_wa.
    callback_wa-ldbnode     = 'SFLIGHT'.
    callback_wa-get         = 'X'.
    callback_wa-cb_prog     = sy-repid.
    callback_wa-cb_form     = 'CALLBACK_SFLIGHT'.
    APPEND callback_wa TO callback.
    seltab_wa-kind = 'S'.
    seltab_wa-selname = 'CARRID'.
    LOOP AT s_carr.
      MOVE-CORRESPONDING s_carr TO seltab_wa.
      APPEND seltab_wa TO seltab.
    ENDLOOP.
    CALL FUNCTION 'LDB_PROCESS'
         EXPORTING
              ldbname                     = 'F1S'
              variant                     = ' '
         TABLES
              callback                    = callback
              selections                  = seltab
         EXCEPTIONS
              ldb_not_reentrant           = 1
              ldb_incorrect               = 2
              ldb_already_running         = 3
              ldb_error                   = 4
              ldb_selections_error        = 5
              ldb_selections_not_accepted = 6
              variant_not_existent        = 7
              variant_obsolete            = 8
              variant_error               = 9
              free_selections_error       = 10
              callback_no_event           = 11
              callback_node_duplicate     = 12
              OTHERS                      = 13.
    IF sy-subrc <> 0.
      WRITE: 'Exception with SY-SUBRC', sy-subrc.
    ENDIF.
    FORM callback_spfli USING name  TYPE ldbn-ldbnode
                              wa    TYPE spfli
                              evt   TYPE c
                              check TYPE c.
      CASE evt.
        WHEN 'G'.
          WRITE: / wa-carrid, wa-connid, wa-cityfrom, wa-cityto.
          ULINE.
        WHEN 'L'.
          ULINE.
      ENDCASE.
    ENDFORM.
    FORM callback_sflight USING name  TYPE ldbn-ldbnode
                                wa    TYPE sflight
                                evt   TYPE c
                                check TYPE c.
      WRITE: / wa-fldate, wa-seatsocc, wa-seatsmax.
    ENDFORM.</b>

  • Target Address for "Marketplace-Adapter" on Marketplace

    Hello,
    we have to use the marketplace-adapter (http and https) to communicate with a marketplace.
    Now we have the problem, which address has to be added on the marketplace-site to send documents to the XI over marketplace-adapter.
    is this address like "http://<host>:<port>/sap/xi/adapter_plain?..." ?
    but which parameter have to be set in this case?
    I didn't find any information about this in the documentation of sap.
    regards,
    thorsten

    Hi Thorsten,
    The url with "adapter_plain" in it is the url to a plain http adapter...it can take parameters as given below...
    however, i am not sure whether this is the url you are looking for ? because this one just passes the payload on to the integration server....it does not do any conversion where as for the message from the market place, the format has to be converted from MML to XI specific format...right?
    i am also trying to search and find the url for accessing the sender market place channel...
    anyways....the parameters for an http adapter are...
    http://hostname:port/path
                         ?namespace=???
                         &interface=???
                         &service=???
                         &party=???
                         &agency=???
                         &scheme=???
                         [&qos= EO|BE|EOIO]
                         [&msgguid=???]
                         [&queueid=???]
                         [&trace=[1|2|3]]
    Thanks,
    Renjith

  • Discovering MAC addresses for Switch ports

    Hello and thanks for looking at my question,
    My company has inherited a network which has some very poor documentation. We really have no clue, nor does the customer, what machines are connected to what switch ports.
    My co-worker and I were discussing the best way to find this out with the least amount of effort, but can't agree on a single solution. Any recommendations would be greatly appreciated.
    Thanks.
    Sincerely,
    Brent

    Brent,
    After you do the 'sho arp' and now have MAC to IP translation, do a 'sho mac-address table' to show MAC to port translation. Save both tables to an Excel spreadsheet and tie them together. You should be able to come up with a good cross reference table (depending upon your Excel skills).
    This also gives you a switch-by-switch breakout. It's also a very helpful troubleshooting method to find rouge devices and shut down a port (for instance).
    Hope this is helpful.
    Jim

  • Dynamic read of file for File Port

    As per our project requirement have to use File Port to pick a set of IDOC Flat files from a given directory. The File Port only allows us to pick a file with a specific given name and does not allow us to pull file with a pattern for .eg. We can pull a file abcd.txt but cannot pull something like abc.txt. Our requirement is to pull abc.txt using the File Port.
    If anyone has any idea about this, or any past experience with File Port in this regard, then please respond at the earliest.
    We have created the file port with follwoing parameters:
    Unchecked the Unicode Format System Setting
    For the Inbound File:
    Function Module: EDI_PATH_CREATE_CLIENT_DOCNUM
    Directory is: A valid directory path
    File Name: abcd.txt

    Hi,
    According to me, while using the automatic syndication through ports, it is not possible to change the filename that IDOC flat file generates.
    FTPS != Secure FTP (990)
    FTPS should have SSH Port 22.
    u can check on this:
    Basic FTP Setup Instructions
    refer this thread also
    FTPS
    Thanks & Regards!!!
    Saurabh Goel

  • OSB Cluster: Defining target server for mailpoll failed (Weblogic 10.3.3.0)

    Hi!
    Deploying is fine without email polling. But with email polling proxy service deployed (Eclipse OEPE) fails with the errormsg:
    *[WliSbTransports:381611]Poller target server should be specified in case of cluster domain.*
    To solve this problem, I've tried to set the target server but not found in weblogic console. The domain created with Configuration Wizard.
    The cluster consists of two managed servers + loadbalancer + adminserver.
    Topology: http://img140.imageshack.us/img140/6128/mozscreenshot69.png
    BEA-381611
    Error: Poller target server should be specified in case of cluster domain.
    Description
         Poller target server should be specified in case of cluster domain.
    Action
         Make sure that the File proxy configuration has one of the managed servers as poller target server if it is running in the cluster.
    Edited by: shuttle on 2011.01.21. 4:14

    Select the managed server in "Managed Server" setting in E-Mail Transport Configuration Page on sbconsole (of your proxy)
    http://download.oracle.com/docs/cd/E14571_01/doc.1111/e15866/transports.htm#i1268939
    Regards,
    Anuj

  • Defining target page for category banner link

    When showing the group by category banner in an item region the category name shows up as a link. I need the target of this link to be a page I can control the look and feel of - how to?

    In Release 2 (9.0.2) and later you can modify the category pages just like any other page, including controlling the attributes that appear. In 9.0.2.6 you can now apply a template to these pages as well.
    In 3.0.x you have limited ability to control the appearance - the folder will pick up the style of the root folder of the page group. Otherwise, the appearance of the folder is fixed.
    Regards,
    Jerry
    PortalPM

  • Java proxy client logical port transport to Q and prod issue in target addr

    Hi All,
    I have a java proxy client having a logical port (configured using NWDS) to consume a web service in the provider system.
    In the logical port, I have given target address, and logical port name. While moving this client proxy NWDI dev track to Q and prod,
    how do I change this target address to point to Q and prod respectively. In other words, even though I am using Visual admin to configure the destination url for the logical port, to point to Q and prod, its still referring to the dev environment provider service after moving the proxy client to Q and prod. What is the suggested approach to take care of this issue
    Thx
    mike

    Hi Michael,
    I can only help from that point of view that I believe this question belongs to the forum
    Service-Oriented Architecture (SOA) and SAP
    Please try to raise this question there.
    Thanks and Regards,
    Ervin

  • Client proxy consuming web service provider using logical port issue

    Hi All,
    I have a proxy client having a logical port (configured using  NWDS)  to consume a web service in the provider system.
    In the logical port, I have given target address, and logical port name. While moving this client proxy NWDI dev track to Q and prod,
    how do I change this target address to point to Q and prod respectively. In other words, even though I am using Visual admin to configure the destination url for the logical port, to point to Q and prod, its still referring to the dev environment provider service after moving the proxy client to Q and prod. What is the suggested approach to take care of this issue
    Thx
    mike

    Hi Michael,
    I can only help from that point of view that I believe this question belongs to the forum
    Service-Oriented Architecture (SOA) and SAP
    Please try to raise this question there.
    Thanks and Regards,
    Ervin

  • Read logical port for the proxy

    HI ,
    There is method  or FM that can bring all the logical port that available for proxy class,
    logical port that defined on SOAMANAGER or LPCONFIG .
    Regards
    Joy

    Try this way
        call function 'RFC_READ_TABLE'
             destination                rfc_sys
             exporting
                  query_table          = 'SRT_LP' " Table for Logical Ports
             tables
                  options              = options1
                  fields               = nametab1
                  data                 = i_srt_lp[].  " Output table contains call values for proxy class after fm call

  • SOA Management - setting up logical port for WS

    Hi
    I'm trying to use the RepositoryFrameworkWS from abap.
    During this i am setting up a logical pot for the webservice.
    This is done through the SOA Management.
    I find the consumer proxy CO_KMCWS_REPOSITORY_FRAMEWORK
    I then try to create the logical port.
    i use the wsdl
    http://<server>:<java_port>/RepositoryFrameworkWS/Config1?wsdl&
    when i apply the settings i get an error.
    SRT Framework exception: The WSDL document is not compatible with proxy class "CO_KMCWS_REPOSITORY_FRAMEWORK": "Operation(s)Missing setGlobalConfig, resetSessionStatistic, resetGlobalStatistic, getSessionStatistic,
    I know the operation i want to use(findResources). But I don't know how to set it up.
    Can anyone help me ?
    Best Regards,
    Rasmus

    Hi Rasmus,
    Please check the Service definition in the WSDL URL given for Logical Port creation is same as the Service definition in the proxy CO_KMCWS_REPOSITORY_FRAMEWORK. It seems to me that  some methods/ operations in th proxy could not be found in the Service definition in the WSDL URL.
    Download the WSDL from the URL and open it using some tool and compare the Service definition with that of the proxy.
    Regards,
    Avishek.

Maybe you are looking for