Forward Delay not working

I have a distributed queue, whose subdeployments points to two JMS Servers each having there own persistent DB store. Now i have configured forward delay of 5 (implying 5 seconds) on the Distributed Queue. So essentially if there are no consumers for a queue for 5 seconds the messages should be forwarded to other member of the distributed queue but the same is not happeneing, the messages never get forwarded to other member in the distributed queue? What could be the problem?

I have already checked the JNDI tree and those show the distributed members correctly.
As you said as of weblogic 9.2 its not queue forward is not encoraged then how come MDBs are able to listen from both queue members.
Eg: Say you have two queue emmebr but when you start your servers only one is accessible so all consumers will listen to queue member QA availbel on jms server JA having database persistent store DA, the other queue member QB available on JMS server JB having database persistent store DB will not be listened to even after the seconds managed server on whch JB is deployed comes back?Yes - MDBs handle all cases automatically.
When an MDB runs on a different cluster/server than its source distributed queue, it automatically creates at least one active consumer on each distributed queue member.
When an MDB is targeted to the same cluster as its source distributed queue, it automatically creates a deployment for each queue member, or, in very limited situations, you may want to configure a behavior that causes each local deployment to connect to every queue member.
The MDB code automatically dynamically handles all cases of changes in member availability such as shutdown, start, new configured members, deleted members, and the migration of members from server to server.
I am not sure if you have can two JMS servers using the same DB Store?No. No two JMS servers can share a DB store unless the JMS servers and DB store all share the same target (and therefore all run on the same WebLogic Server). Even then, the two JMS servers will not manipulate or expose each-other's messages -- they will only expose their own messages.

Similar Messages

  • Call Forwarding Number Not Working

    Hi I have just purchased a skype phone number in Australia  for 3 months and have redirected my calls to a number in the Philippines whilst I am on holidays. When I ring this number (Australia Skype number)  it isnt being diverted to my Philippine phone number. I have added the number and whenever I return to tab the details for Call Forwarding are being erased. Advice appreciated as I am not receiving calls on mobile.

    I am also facing this same problem of Call forwarding no. not working , I am having a Hong Kong Phone skype no. and have diverted to my India no. however when some body calls me on my HK no. the no. is not connected. I am covered with all the subscriptions required for call transfer , Please suggest urgently as i am loosing on reciving calls from all my impotant no.
    hellp reply asap .

  • Port forwarding 3389 not working!! help!! needed urgently

    i am trying to forward the RDP port to a terminal server inside my LAN. but things are not working for me. Router is 801 ISDN
    my config is..
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    hostname edi-ISDN
    ip subnet-zero
    ip name-server 213.x.x.20
    ip name-server 195.x.x.222
    isdn switch-type basic-net3
    nterface Ethernet0
    ip address 192.168.0.254 255.255.255.0
    ip nat inside
    interface BRI0
    no ip address
    ip nat outside
    encapsulation ppp
    dialer pool-member 1
    isdn switch-type basic-net3
    ppp authentication pap callin
    interface Dialer1
    ip address negotiated
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer idle-timeout 500
    dialer string 4004444
    dialer hold-queue 10
    dialer-group 1
    ppp authentication pap callin
    ppp pap sent-username xxxxxxx password xxx
    ip nat inside source list 101 interface Dialer1 overload
    ip nat inside source static tcp 192.168.0.100 3389 interface Dialer1 3389
    no ip http server
    ip classless
    ip route 0.0.x.x x.0.0.0 Dialer1
    access-list 1 permit 192.168.0.0 0.0.0.255
    access-list 101 permit ip 192.168.0.0 0.0.0.255 any
    dialer-list 1 protocol ip permit
    line con 0
    password xxx
    transport input none
    stopbits 1
    line vty 0 4
    password xxx
    login
    no rcapi server
    the ip nat translation output was
    Pro Inside global Inside local Outside local Outside global
    udp 86.96.x.x:1166 192.168.0.123:1166 86.96.60.5:123 86.96.60.5:123
    udp 86.x.x.249:123 192.168.0.100:123 192.168.79.1:123 192.168.79.1:123
    tcp 86.96.130.249:3824 192.168.0.123:3824 64.152.73.172:80 64.152.73.172:80
    udp 86.x.x.249:123 192.168.0.100:123 192.168.56.1:123 192.168.56.1:123
    tcp 86.96.130.249:3389 192.168.0.100:3389 --- ---
    udp 86.96.130.249:1143 192.168.0.123:1143 213.42.20.20:53 213.42.20.20:53
    edi-ISDN#show ip nat trans
    Pro Inside global Inside local Outside local Outside global
    udp 86.96.130.249:1166 192.168.0.123:1166 86.96.60.5:123 86.96.60.5:123
    udp 86.96.130.249:123 192.168.0.100:123 192.168.79.1:123 192.168.79.1:123
    tcp 86.96.130.249:3824 192.168.0.123:3824 64.152.73.172:80 64.152.73.172:80
    udp 86.96.130.249:123 192.168.0.100:123 192.168.56.1:123 192.168.56.1:123
    tcp 86.96.130.249:3389 192.168.0.100:3389 --- ---
    udp 86.96.130.249:1143 192.168.0.123:1143 213.42.20.20:53 213.42.20.20:53

    update ip nat translation shows that the connection touches the outside interface(dialer1) of the router but then it disconnects.
    =====================================
    Pro Inside global Inside local Outside local Outside global
    tcp 86.96.131.184:80 192.168.0.100:80 --- ---
    tcp 86.96.131.184:3389 192.168.0.100:3389 86.96.139.115:29083 86.96.139.115:29083
    tcp 86.96.131.184:3389 192.168.0.100:3389 --- ---

  • Forward button not working on last page of module with links

    CP4 - When I have links on a page, I select the Pause until User clicks option on the click box for the link. This pauses the module until the user has an opportunity to look at the material when they click a link. The Forward button works fine when they come back to the module. However, it does not work on the last page of a module, Forward will not go to the next module -- the Play button must be pushed to Forward to the next module. I have the Preferences Start/End to open another project when they reach the end.
    Can anyone tell me why the Forward button isn't working on the last page when there are links on that page?
    Thank you so much.
    Laraine

    I did a work around which is time consuming and inefficient.  I duplicated the slide, removed the link click box and made the animations static. I also set the slide time length to 0.1, now the forward button on the previous slide works.

  • Forwarding document (not work item) from specific SAP workflow to Outlook

    Hi,
    We are looking for ways to forward the email notification of leave approval from SAP inbox to MS Outlook.
    One way I know of is to create Auto forwarding in SAP inbox, however this would forward all documents received regardless of the work flow.
    Would appreciate it if any one out there could share your experience.
    Thanks.
    Siew May

    Use program RSWUWFML2.  You can get pretty fancy with it to setup wrapper text.  I have used it a lot so feel free to ping me with any questions.
    What is important to know is normal 'email' forwarding will not send workflow items.  I use this every 15 minutes to forward to Outlook and get the users into the Portal to manage the workflow.

  • Back Forward arrows not working properly Safari 5.1.2

    After upgrading to Safari 5.1.2 on Snow Leopard, I have run into a bug with the back and forward arrows. Most of the time they are greyed out and not working. I have to move back and forward with either the keyboard shortcut or the menu. Sometimes one or the other starts to work, but it is not clear why. I have not seen both working yet.

    Here is what comes up (a lot!). I feel like the days of  "Conflict Catcher" with MacOS 9 and before! Anyway, it is late here, maybe where you are, too. Thanks for all the quick replies. I need to get some sleep and will come back to this in the morning.
    kextstat -kl | awk ' !/apple/ { print $6 $7 } '
    com.Logitech.ControlCenter.HID
    com.iospirit.driver.rbiokithelper(1.7.2)
    com.rogueamoeba.HermesAudio(4.1.0)
    com.markspace.iokit.IOMissingSyncMassStorage(191)
    com.IPEVO.driver.IPEVO(1.2)
    com.Cycling74.driver.Soundflower(1.5.1)
    com.rogueamoeba.hermes(4.1.0)
    com.parallels.kext.prl_hypervisor(5.0
    com.sophos.kext.sav(7.3.0)
    com.vmware.kext.vmx86(2.0.6)
    com.parallels.kext.prl_hid_hook(5.0
    com.vmware.kext.vmci(2.0.6)
    com.parallels.kext.prl_usb_connect(5.0
    com.vmware.kext.vmioplug(2.0.6)
    com.parallels.kext.prl_netbridge(5.0
    com.vmware.kext.vmnet(2.0.6)
    com.parallels.kext.prl_vnic(5.0
    sudo launchctl list | sed 1d | awk ' !/0x|apple|com\.vix|edu\.|org\./ { print $3 } '
    com.parallels.vm.prl_naptd
    net.videosurgeon.Video-Snooper
    com.wdc.drivemanagerservice
    com.vmware.launchd.vmware
    com.sophos.notification
    com.sophos.intercheck
    com.sophos.autoupdate
    com.rogueamoeba.hermes
    com.parallels.desktop.launchdaemon
    com.google.keystone.daemon
    com.freemacsoft.appcleanerd
    com.bjango.istatlocaldaemon
    com.barebones.textwrangler
    com.adobe.versioncueCS3
    launchctl list | sed 1d | awk ' !/0x|apple|edu\.|org\./ { print $3 } '
    com.wacom.pentablet
    com.parallels.desktop.client.launch
    com.Logitech.Control
    com.google.keystone.root.agent
    com.brother.LOGINserver
    com.bjango.istatlocal
    com.artificialmachines.TextWand
    ws.agile.1PasswordAgent
    net.infinite-labs.PlugSuit.Agent
    com.valvesoftware.steamclean
    com.tastyapps.SpiceRack
    com.ecamm.printopia
    com.cnet.ttengine
    com.adobe.ARM.ad895013aeb33ea6e968d9fdc06c0eb42c7c2a5229d98d64ad002716
    com.adobe.ARM.202f4087f2bbde52e3ac2df389f53a4f123223c9cc56a8fd83a6f7ae
    ls -1A {,/}Library/{Ad,Compon,Ex,Fram,In,La,Mail/Bu,P*P,Priv,Qu,Scripti,Servi,Sta}* 2> /dev/null
    /Library/Address Book Plug-Ins:
    .DS_Store
    BTGoogleDirections.bundle
    BTGoogleEarth.bundle
    BTGoogleMaps.bundle
    BTGooglePreferences.bundle
    PostCheck.bundle
    /Library/Components:
    /Library/Extensions:
    /Library/Frameworks:
    .DS_Store
    AECore.framework
    Adobe AIR.framework
    Compressor.framework
    DivX Toolkit.framework
    EWSMac-GC.framework
    EWSMac.framework
    FxPlug.framework
    GlimsAdditions.framework
    GoogleMapsShared.framework
    MacFUSE.framework
    MediaServerAPI.framework
    Motion.framework
    NyxAudioAnalysis.framework
    ONCore.framework
    ONDocument.framework
    ONPSEmulator.framework
    ONProxySupport.framework
    ONlibapr-osx.dylib
    ONlibapr-util-osx.dylib
    ONlibjpeg-osx.dylib
    OnOneWidgets.framework
    PluginManager.framework
    ProFX.framework
    Qmaster.framework
    SAVI.framework
    SUMScanKit.framework
    TSLicense.framework
    onOneToolbox.framework
    /Library/Input Methods:
    /Library/InputManagers:
    1PasswdIM
    GearsEnabler
    GrowlSafari
    SIMBL
    Smart Crash Reports
    SparkPlug
    /Library/Internet Plug-Ins:
    .DS_Store
    AdobePDFViewer.plugin
    CANONiMAGEGATEWAYDL.plugin
    ContentUploaderPlugin.plugin
    CoolirisWebKitPlugin.plugin
    CouponPrinter-FireFox.plugin
    CouponPrinter-Safari.webplugin
    DirectorShockwave.plugin
    Disabled Plug-Ins
    DivXBrowserPlugin.plugin
    Flash Player.plugin
    Flip4Mac WMV Plugin.plugin
    Gears.plugin
    Google Earth Web Plug-in.plugin
    JavaAppletPlugin.plugin
    MacCouponPrinter3.plugin
    PDF Browser Plugin.plugin
    Quartz Composer.webplugin
    QuickTime Plugin.plugin
    RealPlayer Plugin.plugin
    Scorch.plugin
    ShiVa3D.plugin
    Silverlight.plugin
    Yahoo! Installer 3.plugin
    flashplayer.xpt
    googletalkbrowserplugin.plugin
    huludesktop.webplugin
    iPhotoPhotocast.plugin
    npUpload.xpt
    npdivx.xpt
    npgtpo3dautoplugin.plugin
    nsIQTScriptablePlugin.xpt
    /Library/LaunchAgents:
    com.Logitech.Control Center.Daemon.plist
    com.artificialmachines.TextWand.plist
    com.bjango.istatlocal.plist
    com.brother.LOGINserver.plist
    com.cooliris.SetLaunchArch.plist
    com.google.keystone.agent.plist
    com.parallels.desktop.launch.plist
    com.teamviewer.teamviewer.plist
    com.teamviewer.teamviewer_desktop.plist
    com.wacom.pentablet.plist
    org.glimmerblocker.updater.plist
    /Library/LaunchDaemons:
    com.adobe.versioncueCS3.plist
    com.apple.third_party_32b_kext_logger.plist
    com.barebones.textwrangler.plist
    com.bjango.istatlocaldaemon.plist
    com.freemacsoft.appcleanerd.plist
    com.google.keystone.daemon.plist
    com.parallels.desktop.launchdaemon.plist
    com.rogueamoeba.hermes.plist
    com.sophos.autoupdate.plist
    com.sophos.intercheck.plist
    com.sophos.notification.plist
    com.teamviewer.teamviewer_service.plist
    com.vmware.launchd.vmware.plist
    com.wdc.drivemanagerservice.plist
    net.videosurgeon.Video-Snooper.plist
    org.glimmerblocker.proxy.plist
    /Library/Mail/Bundles:
    .DS_Store
    /Library/PhonePlugins:
    Samsung-D347.phoneplugin
    Samsung-D357.phoneplugin
    Samsung-D407.phoneplugin
    Samsung-D807.phoneplugin
    Samsung-T519.phoneplugin
    Samsung-T609.phoneplugin
    Samsung-T629.phoneplugin
    Samsung-T719.phoneplugin
    Samsung-T729.phoneplugin
    /Library/PreferencePanes:
    Apple Qmaster.prefPane
    Archives.prefPane
    Candelair.prefPane
    DivX.prefPane
    EarthDesk.prefPane
    Flash Player.prefPane
    Flip4Mac WMV.prefPane
    GlimmerBlocker.prefPane
    Growl.prefPane
    HyperDock.prefpane
    Logitech Control Center.prefPane
    MacFUSE.prefPane
    PenTablet.prefPane
    Perian.prefPane
    VersionCueCS3.prefPane
    /Library/PrivilegedHelperTools:
    com.barebones.textwrangler
    com.freemacsoft.appcleanerd
    net.videosurgeon.Video-Snooper
    /Library/QuickLook:
    .DS_Store
    GBQLGenerator.qlgenerator
    ParallelsQL.qlgenerator
    QuickLookEyeTV.qlgenerator
    VMware Fusion QuickLook.qlgenerator
    iWork.qlgenerator
    /Library/QuickTime:
    .DS_Store
    AppleHDVCodec.component
    AppleIntermediateCodec.component
    AppleMPEG2Codec.component
    CanonMJPEGAVI.component
    CanonMJPEGAVIDec.component
    CanonText.component
    DVCPROHDCodec.component
    DVCPROHDMuxer.component
    DVCPROHDVideoDigitizer.component
    DVCPROHDVideoOutput.component
    DVCPROHDVideoOutputClock.component
    DVCPROHDVideoOutputCodec.component
    DesktopVideoOut.component
    DivX Decoder.component
    DivX Encoder.component
    EyeTV MPEG Support.component
    FCP Uncompressed 422.component
    FLV.component
    Flip4Mac WMV Advanced.component
    Flip4Mac WMV Export.component
    Flip4Mac WMV Import.component
    Google Camera Adapter 0.component
    Google Camera Adapter 1.component
    IMXCodec.component
    LiveType.component
    Motion.component
    Toast Video CD Support.qtx
    /Library/ScriptingAdditions:
    Adobe Unit Types.osax
    /Library/Services:
    .DS_Store
    Add to Web Clips.workflow
    Browse Movie Library.workflow
    Browse Photo Library.workflow
    Browse iTunes Library.workflow
    Create Formatted Link for Front Document.workflow
    Currency Converter.workflow
    Keynote Pie Chart from 2-Column Selection.workflow
    New Event for Selected Date.workflow
    Pages Pie Chart from 2-Column Selection.workflow
    Print Selection.service
    PrintSelection.services
    Search in YouTube.workflow
    WordService.service
    /Library/StartupItems:
    MissingSyncMounting
    ParallelsDesktopTransporter
    Qmaster
    Library/Address Book Plug-Ins:
    .DS_Store
    AdiumAddressBookAction_AIM.scpt
    AdiumAddressBookAction_ICQ.scpt
    AdiumAddressBookAction_Jabber.scpt
    AdiumAddressBookAction_MSN.scpt
    AdiumAddressBookAction_SMS.scpt
    AdiumAddressBookAction_Yahoo.scpt
    SkypeABDialer.bundle
    SkypeABSMS.bundle
    Library/Components:
    Spell Catcher.component
    Library/Frameworks:
    GoogleMapsShared.framework
    Library/Input Methods:
    .localized
    Library/Internet Plug-Ins:
    GlimsAddition.notplugin
    Instant Action.plugin
    Picasa.plugin
    Library/LaunchAgents:
    com.adobe.ARM.202f4087f2bbde52e3ac2df389f53a4f123223c9cc56a8fd83a6f7ae.plist
    com.adobe.ARM.ad895013aeb33ea6e968d9fdc06c0eb42c7c2a5229d98d64ad002716.plist
    com.apple.SafariBookmarksSyncer.plist
    com.cnet.ttengine.plist
    com.ecamm.printopia.plist
    com.tastyapps.SpiceRack.plist
    com.valvesoftware.steamclean.plist
    net.infinite-labs.PlugSuit.Agent.plist
    ws.agile.1PasswordAgent.plist
    Library/Mail/Bundles:
    .DS_Store
    GrowlMail.mailbundle
    MailRecent.mailbundle
    Library/Mail/Bundles (Disabled 1):
    GrowlMail.mailbundle
    Library/Mail/Bundles (Disabled):
    Library/PreferencePanes:
    Perian.prefPane
    Printopia.prefPane
    SpiceRack.prefPane
    TechTracker.prefPane
    Library/QuickTime:
    AC3MovieImport.component
    Perian.component
    Library/ScriptingAdditions:
    1Password Addition.osax
    Paperless Addition.osax
    SpiceShaker.osax
    Library/Services:
    Spell Catcher Services.service
    ToastIt.service

  • Magic Mouse two finger swipe (forward/back) not working with Opera 10.

    Magic Mouse left and right two finger swipe (forward and back) works great with Safari, Firefox, and Camino.
    I enjoy using Opera 10 and noticed that the two finger swipe does not function with Opera. Any ideas on why or what adjustments I can make to get it to work?

    No workaround so far with this problem and also no posts in the Opera forums. Just have to wait until Opera includes this functionality in their next release.
    In the meantime you can help by joining the forum (takes a minute) and posting your concern. The more people that join and voice their complaint the faster something will get coded into their browser.

  • HT4061 My forward camera not working

    My forward camera is not working what can I do about it.

    Very vague...
    johnny solis wrote:
    my password is not working
    Is this your issue...
    Activation Lock in iOS 7  >  http://support.apple.com/kb/HT5818

  • HELP! forwarding is not working

    Hi everybody: would somebody mind to look at the page
    http://www.neue-reichskanzlei.de/passwordD.htm
    since the forwarding after the sign in does not work. it use to
    work on the old server but since we changed the server it is not
    working. any suggestions? the code you can put in to try it out is:
    dbr-3653
    Any suggestions are appreciated! thank you guys so much.
    Leo

    if you are using php one thing to look at is output
    buffering. if you are using a header without output buffering you
    must do so before you print anything on the page.

  • My bookmarks & browsing history has disappeared. Backward & forward arrows not working. How can I get this back working?

    Message I'm receiving from Firefox is "The bookmarks and history system will not be functional because on of Firefox's files is in use by another application. Some security software can cause this problem." I have not made any changes on my computer. I did uninstall and reinstall Firefox but bookmarks and history system still not working. I am using the latest version of Firefox on Windows Vista.
    Thanks

    This indicates that there is a problem with the file that stores the bookmarks and history. Re-installing Firefox does not by default remove the profile folder where that file is stored. See [http://kb.mozillazine.org/Locked_or_damaged_places.sqlite Locked or damaged places.sqlite - MozillaZine Knowledge Base]

  • When Firefox 3.5.16 is opened in OS 10.6 on Mac, the bookmarks and history are missing as well as back/forward arrows not working.

    I have a laptop running Firefox 3.5.16 and Mac OS 10.6.5. I used my computer last night without any problem. This afternoon, I had a USB modem plugged in when I started my machine and at first Firefox said it couldn't connect. After removing the USB modem, I restarted without it in the machine, then connected to the Internet and started Firefox. I had a Firefox error message about bookmarks not working due to another application using them. I checked the troubleshooting pages, but for the most part they applied to a Windows machine.

    I finally found a solution. In about:config, under browser.sessionhistory.max_entries, I changed 5 to 20. End of problem.

  • Call forward feature not working on remote app on ipad

    I can not activate called forwarding of my house phone from my ipad or iphone. The pop up box does not allow the ok to work.

    Hi Josie,
    Fios Digital Voice is our only phone service that allows you to manage call forwarding on your Fios app.
    If you do in fact have Fios Digital Voice, then please try uninstalling and reinstalling your app and let us know if that works.
    ~Jess

  • Balance forward billing not working on r12.1.3

    Hi,
    I am unable to work on the Balance forward billing, the bill date is not getting generated.
    Can you please send me the solution for BFB for 12.1.3, also I need to customize the BFB to be based on Customer PO number and not date.
    Thanks in Advance.
    Regards,
    Chirag

    Hi
    If you give correct db connection properties in db adaptor's wsdl , it will work. If jndi properties were not available in db adaptor's wsdl file, then bpel server will pick jndi properties from oc4j-ra.xml.
    Give system name instead of IP address of database server in mcf.ConnectionString property. This will work.
    Krish

  • Linksys e1200 PORT RANGE FORWARDING is not working

    I currently have an E1200. I can port forward single ports, but when I attempt to forward a range of ports it doesn't work and there is no error in the log.
    Specifically I am port forwarding RTP ports (10000 - 20000). I am aware of the security risks, please do not preach.

    I have a problem with port forwarding http port 80 this for i surveillance camera.
    I have all the settings are correct but I can not convert. Opening this port Also no other ports open. Who can help me on the way to this is to get together. I mtu gezte the firewall function in 1400 and put on the standard port 80 http to put. and of course the ip address that is in the same range.
    I do not know what I'm doing wrong because the old linksys just worked. It I hope someone can help me.

  • DNS Forward Lookups Not Working

    My DNS experience and knowledge is pretty limited. Having said that it appears that our xserves can do reverse lookups for both of our xserves, but can't do a forward lookup. How can I fix this?
    Here are the lookup information from network utility:
    Lookup has started ... dataxserve.w.k12.ia.us
    ; <<>> DiG 9.3.4 <<>> dataxserve.w.k12.ia.us
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 37918
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    ;; QUESTION SECTION:
    ;dataxserve.w.k12.ia.us. IN A
    ;; Query time: 0 msec
    ;; SERVER: 192.168.0.3#53(192.168.0.3)
    ;; WHEN: Tue Jan 15 13:26:53 2008
    ;; MSG SIZE rcvd: 49
    Lookup has started ... 192.168.0.3
    ; <<>> DiG 9.3.4 <<>> -x 192.168.0.3
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 19034
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0
    ;; QUESTION SECTION:
    ;3.0.168.192.in-addr.arpa. IN PTR
    ;; ANSWER SECTION:
    3.0.168.192.in-addr.arpa. 86400 IN PTR dataxserve.w.k12.ia.us.
    ;; AUTHORITY SECTION:
    0.168.192.in-addr.arpa. 86400 IN NS dataxserve.w.k12.ia.us.
    0.168.192.in-addr.arpa. 86400 IN NS xserve.w.k12.ia.us.
    ;; Query time: 0 msec
    ;; SERVER: 192.168.0.3#53(192.168.0.3)
    ;; WHEN: Tue Jan 15 13:32:01 2008
    ;; MSG SIZE rcvd: 122
    Lookup has started ...xserve.w.k12.ia.us
    ; <<>> DiG 9.3.4 <<>> xserve.w.k12.ia.us
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 10240
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    ;; QUESTION SECTION:
    ;xserve.w.k12.ia.us. IN A
    ;; Query time: 0 msec
    ;; SERVER: 192.168.0.3#53(192.168.0.3)
    ;; WHEN: Tue Jan 15 13:32:52 2008
    ;; MSG SIZE rcvd: 45
    Lookup has started ...192.168.0.2
    ; <<>> DiG 9.3.4 <<>> -x 192.168.0.2
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 49722
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0
    ;; QUESTION SECTION:
    ;2.0.168.192.in-addr.arpa. IN PTR
    ;; ANSWER SECTION:
    2.0.168.192.in-addr.arpa. 86400 IN PTR xserve.w.k12.ia.us.
    ;; AUTHORITY SECTION:
    0.168.192.in-addr.arpa. 86400 IN NS xserve.w.k12.ia.us.
    0.168.192.in-addr.arpa. 86400 IN NS dataxserve.w.k12.ia.us.
    ;; Query time: 0 msec
    ;; SERVER: 192.168.0.3#53(192.168.0.3)
    ;; WHEN: Tue Jan 15 13:33:26 2008
    ;; MSG SIZE rcvd: 122
    Please help

    Hi
    You don't have to if you don't want to. You can leave both servers running internal DNS Services. The DHCP Service does not require DNS. It all depends on how you want to push out network services to your clients.
    I don't know your particular circumstances but its not absolutely necessary to run DNS on your mail server. It depends a great deal on how you want the server to handle mail for your domain. I'm not an expert but the way I generally do a mail server is to use external MX Records and duplicate the external record internally. Its a fairly simple method and should send and receive mail for your clients internally as well as externally.
    You could configure internal DNS Services on one server only and just add a machine record for the second server. You could expand on this and configure DNS Services on both servers with a machine record for each server on both. There is enough in the GUI to allow you to do this. For example server01.mydomain.com with an IP address of 192.168.254.254 and server02.mydomain.com with an IP address of 192.168.254.253. This way if one server was to go down the other server should still provide a DNS Service to your local clients. However without knowing fully your network environment and your requirements its difficult to advise.
    However is this a new setup and are you trying to get it to work? Or has it been working OK for a while and something has broken it? If its the latter what errors are you seeing?
    If you want to know more about DNS purchase a copy of Paul Ablitz and Cricket Lui's book 'DNS & Bind' and start reading.
    Hope this helps, Tony

Maybe you are looking for