Ipv4 from dhcp, ipv6 static on single interface eth0

Hi,
pls help me understand or solve my problem with my network setup.
I had ipv4 ip address assigned dynamically and ipv6 set statically, both via netcfg and everything worked without problem.
This is my netcfg config:
CONNECTION='ethernet'
DESCRIPTION='A basic dhcp ethernet connection using iproute'
INTERFACE='eth0'
IP='dhcp'
PRE_UP='ethtool -s eth0 wol g'
PRE_DOWN='ethtool -s eth0 wol g'
## for IPv6 autoconfiguration
#IP6='stateless'
## for DHCPv6
IP6='static'
ADDR6=(2002:54f2:xxxx:1::2/64)
GATEWAY6=2002:54f2:xxxx:1::1
But someday I received error when booting up and also when I try to start profile manualy:
/etc/rc.d/net-profiles start
:: eth0 up
RTNETLINK answers: File exists
Adding gateway 2002:54f2:xxxx:1::1 failed
No profile started.
I found that I can't have two gateways on one interface, but until now there's no problem.
When I disabled GATEWAY6 line from config, eth0 profile can be started but ipv6 connectivity didn't works.
I tried set ipv6 to stateless that works, but after some time not more that 5min network connection resets and after recovery in couple of seconds only ipv4 works.
Where's a problem? What can I do to achieve same setup I had before some update last week?
Thanks

houmles wrote:I found that I can't have two gateways on one interface, but until now there's no problem.
I suspect it's a problem with that; I've noticed this problem as well.
When trying to add multiple default gateways with iproute2 (ie, `ip r a default via xxx:xxx:xxx::xxxx`) it errors with the error you've mentioned. I'm not sure if this is a kernel bug, iproute2 bug, or not a bug at all.
Having multiple default IPv4 gateways works fine.
I believe netcfg doesn't check for an existing gateway and delete it first (or use `ip r r` instead or `ip r a`) before adding the one; but I haven't checked the code so I could be wrong.
EDIT:
OK, I couldn't resist looking at the code, and it indeed does a 'dumb' addition of the gateway:
112 if [[ -n "$GATEWAY" ]]; then
113 report_debug ethernet_iproute_up ip route add default via "$GATEWAY" dev "$INTERFACE"
114 if ! ip route add default via "$GATEWAY" dev "$INTERFACE"; then
115 report_iproute "Adding gateway $GATEWAY failed"
116 fi
117 fi
I'm looking at making a patch now. Patch and bug report: https://bugs.archlinux.org/task/29480
Last edited by fukawi2 (2012-04-16 01:00:09)

Similar Messages

  • [SOLVED] Help with going from dhcp to static ip

    So right now I'm using dhcp on my arch box, but for personal reasons (file server, print server, etc...) I'd like to assign a static ip to the machine.
    I've noticed that when I get a ip via dhcp, there are different broadcast ips, and frankly, I'm just getting confused. I was wondering if there was a way (probably) to setup a static ip from setting that are retrieved via dhcp.
    I know that there's a wiki page as to how to set up a static ip, but there are still some things that I don't understand, so I'd like to know what information I'd need to get from dhcp in order to set up a static ip (essentially the same ip, but it would remain the same)
    I will blatantly admit that networking is not one of my strong suites...
    Last edited by ZeroTruths (2009-09-03 01:20:29)

    When you have a dhcp address, use ifconfig to identify the address, broadcast address, and subnet mask, and use route to identify your default gateway. All these should be added to the rc.conf NETWORKING section - an example is provided. Make a note of the nameserver address that was automatically added to /etc/resolv.conf under dhcp - it should remain there.
    Before you do all that, you may have the option of using a dhcp fixed lease instead i.e. continue to use dhcp, but configure it to provide the same address to your arch box every time. That would depend on the capabilities of the system that provides the dhcp service.

  • IP is from dhcp or static?

    Is there any way to find the ip assigned is from dhcp server or it assigned permanently?
    Thanks

    Hello.
    Under Solaris 9 if you type "ifconfig -a" an additional flag "DHCP" is shown if the IP address came from a DHCP server.
    This is the case because in this case additonal handling (e.g. lease renewal) must be done...
    Martin

  • RRAS 2012 - Cannot Change IPV4 From DHCP -- Static Address Pool

    Have set up RRAS/DA 2012 and it works but I need to change from using our DHCP server to a static address pool.    However, when I go to RRAS server properties & IPv4 tab the section to opt for DHCP/Static is dimmed out.
    Any suggestions to get around this annoyance so I can use static address pools for remote users?
    Thanks as always!

    Hi,
    Please try to use the following PowerSHell command and see how it works.
    Set-VpnIPAddressAssignment -IPAssignmentMethod ‘StaticPool’
    Set-VpnIPAddressAssignment
    http://technet.microsoft.com/en-us/library/hh918431.aspx
    Hope this helps.
    Jeremy Wu
    TechNet Community Support

  • Change from dhcp to static

    i set up a mac mini server running latest 10.6 server software dhcp. it now needs static addressing as the whole network is getting revamped. is it true you need to do this via terminal only as other things can break? can someone please give me the networksetup syntax to change all fields ip subnet etc?

    No, its not true that you can only do this via terminal, but there is a terminal command that goes through and updates the configuration in multiple places that you might forget to do manually, so it makes it easier.
    Don't be afraid of the terminal. The command is just:
    sudo changeip <directory> <current_ip> <new_ip> <current_hostname> <new_hostname>
    Where <directory> is the address of the directory server. If this machine is the directory server just use '/LDAPv3/127.0.0.1' (although you'll have a bigger problem re-mapping all your clients to the new address).
    <current_ip> is the machine's current (DHCP) IP address
    <new_ip> is the new (static) address you're changing to.
    <current_hostname> is the machine's current hostname
    <new_hostname> is the new hostname for the machine
    (the last two options can be omitted if you're not changing the machines hostname).

  • IPV6 clients cannot ping each other while getting IP from DHCP server running in windows 2008

    I have two windows 7 clients and a windows 2008 server connected to a switch with static IP 172:16:5::1/64.
    DHCP server is configured with static IP 172:16:5::20/64
    when i statically assign IP to windows 7 clients like 172:16:5::21 & ::22, they can ping each other. if they get ip from DHCP server, they cannot ping each other.
    if i configure the gateway (172:16:5::1) in the clients manually, they can ping each other.
    is there any way we can make dhcp server to give gateway to the clients along with IP?

    From what I have gathered:
    IPv6 won't route because the DHCP server is setup in 'stateless' mode and the switches do not support IPv6. (
    "But if your routers are not IPv6 supported (yet), you can
    reconfigure DHCPv6 to Disable Stateless mode, and that'll issue IPv6 addresses that
    will eliminate the Ping problem." -
    http://www.networkworld.com/article/2228461/microsoft-subnet/setting-up-dhcpv6-to-dynamically-issue-ipv6-addresses-in-a-network.html)
    So you must change to 'disable stateless' mode. Which the only way I can THINK to do this is to uninstall DHCP and reinstall DHCP and select 'disable stateless' during the installation (which I haven't confirmed). (In
    case, “Disable DHCPv6 stateless mode for this server” option was selected duringrole installation" -
    http://blogs.technet.com/b/teamdhcp/archive/2009/03/03/dhcpv6-understanding-of-address-configuration-in-automatic-mode-and-installation-of-dhcpv6-server.aspx)
    zz.. but my understanding of DHCP is fragmented, please take what I find with a grain of salt. I am off to reinstall DHCP :] .. fun.
    Mediocre Access 2010 | (Baby) Beginner C Sharp | OK at Active Directory (2012) | Fragmented understanding of DNS/DHCP | Laughable experience with Group Policy | Expert question asker on MSDN Forums

  • Can't set ipv6 static address

    As the topic states, I can not setup a static IP to save my life. I've enabled ipv6, I have a hostname6.ce1 I put the hostname (madrid-ipv6) in the hostname6.ce1 file but it will not stay set.
    I've tried the addif command, and it creates a logical interface, but I can't ping out with the address that is set.
    I'm sure I am missing something, and I am new to Solaris. I've got ipv6 static addresses setup in linux with no problems. It's just Solaris 10 that is kicking my butt.
    If anyone can point me in the right direction I would be in your debt.
    Thanks!

    edit: To darren: I've tried that as well. When the system boots, it gives me the error: "Failed to assign ipv6 address to ce1" or something similar to that.
    hmmm, I've tried that, it still doesn't seem to be working. Here is my hostname6.ce1 file:
    madrid-ipv6
    addif fd01::e2/64 up
    this is the output of ifconfig -a6:
    bash-3.00# ifconfig -a6
    lo0: flags=2002000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv6,VIRTUAL> mtu 8252 index 1
    inet6 ::1/128
    ce0: flags=2004841<UP,RUNNING,MULTICAST,DHCP,IPv6> mtu 1500 index 2
    inet6 fe80::203:baff:fe9b:92d/10
    ether 0:3:ba:9b:9:2d
    ce1: flags=2000840<RUNNING,MULTICAST,IPv6> mtu 1500 index 3
    inet6 fe80::203:baff:fe9b:92d/10
    ether 0:3:ba:9b:9:2d
    ce1:1: flags=2000841<UP,RUNNING,MULTICAST,IPv6> mtu 1500 index 3
    inet6 fd01::e2/64
    and this is what I get when I ping fd01::f2:
    bash-3.00# ping fd01::f2
    ICMPv6 Address Unreachable from gateway fd01::e2
    for icmp6 from fd01::e2 to fd01::f2
    ICMPv6 Address Unreachable from gateway fd01::e2
    for icmp6 from fd01::e2 to fd01::f2
    ICMPv6 Address Unreachable from gateway fd01::e2
    for icmp6 from fd01::e2 to fd01::f2
    I've got to be missing something. This is all on a private switch that doesn't need to connect to the net. I need to connect an iscsi VTL to this sun system but the first step is to be able to ping the damn thing. I've checked the networking to make sure everything is connected. I can ping the VTL using IPV4, but not IPV6. I've checked on a linux system and it can ping the VTL over IPV6 so I know it is setup properly. This is just driving me nuts.
    Edited by: jonwheeler on Sep 11, 2008 9:47 AM

  • Router connected to cable modem by Ethernet port cannot get IP address from DHCP.

    I have an ethernet cable on Fa0/0 connecting my 1841 router to my cable modem. The issue is that the router cannot obtain an IP address via DHCP when I have the "ACL-OUTSIDE-IN" ACL applied inbound on the Fa0/0 interface. I tried to allow all BOOTP and BOOTPS traffic in my ACL, but still no luck. I really don't want to run the router without a simple ACL firewall and connect it to the internet. When I take off the ACL off of Fa0/0, the router is able to get an IP address via DHCP.
    Router#sh run
    Building configuration...
    Current configuration : 10736 bytes
    ! Last configuration change at 18:14:42 MST Fri Nov 16 2012 by matt.chan
    version 12.4
    service nagle
    service timestamps debug datetime msec localtime show-timezone year
    service timestamps log datetime msec localtime show-timezone year
    service password-encryption
    hostname Router
    boot-start-marker
    boot system flash:c1841-advipservicesk9-mz.124-25f.bin
    boot-end-marker
    logging count
    logging userinfo
    logging buffered 1048576 informational
    enable secret 5 <removed>
    aaa new-model
    aaa authentication login AUTH-LOCAL local-case
    aaa session-id unique
    memory-size iomem 25
    clock timezone MST -7
    ip cef
    ip nbar pdlm flash:directconnect.pdlm
    ip nbar pdlm flash:citrix.pdlm
    ip nbar pdlm flash:bittorrent.pdlm
    ip nbar custom steam destination udp range 27000 27030
    ip nbar custom rdp destination tcp range 3389 3391 55402
    ip domain lookup source-interface FastEthernet0/0
    ip name-server 8.8.8.8
    ip inspect name fa0/0_inspect_ou icmp router-traffic timeout 10
    ip inspect name fa0/0_inspect_ou ftp timeout 300
    ip inspect name fa0/0_inspect_ou udp router-traffic timeout 120
    ip inspect name fa0/0_inspect_ou tcp router-traffic timeout 300
    login block-for 60 attempts 4 within 60
    login quiet-mode access-class ACL-ACCESS-QUIET
    password encryption aes
    crypto pki trustpoint TP-self-signed-1755372391
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1755372391
    revocation-check none
    rsakeypair TP-self-signed-1755372391
    crypto pki certificate chain TP-self-signed-1755372391
    certificate self-signed 01
      3082023F 308201A8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 31373535 33373233 3931301E 170D3132 31313137 30313130
      35325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 37353533
      37323339 3130819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100D53F 9EB5B123 3103A4D5 82E786F7 F91C2DE5 9E409A22 80AF78F6 812F624A
      89FE9103 73C4AAAB 13FF880D F628607D 6888AC49 18BEDD77 778F0DB1 F9A796E9
      E92717CD 6DD19450 5066620A 91278C33 E38349EA 92B8C671 80761609 0AC46E6F
      2C8C6BCF ABC7E1F7 A64BD28C C85477FE B23F8A7C 555ECDF9 CE461B8D 6C017370
      0ED70203 010001A3 67306530 0F060355 1D130101 FF040530 030101FF 30120603
      551D1104 0B300982 074E5543 4C455553 301F0603 551D2304 18301680 146CA2E0
      936C651F E2ED4DCD D7025FF3 2AB029E0 95301D06 03551D0E 04160414 6CA2E093
      6C651FE2 ED4DCDD7 025FF32A B029E095 300D0609 2A864886 F70D0101 04050003
      8181004A AFA4D07C 1424DE0E EF3F17F2 BB1EA63B CB17C13D 1AEA31A1 BAB6AF77
      DB6EA8A2 2117DCD1 5530A18C 3618D568 CC7EF520 E039ACBD DA906352 BB7E51BD
      0954490C B2AB30C2 FBBE4738 C214BE1C CB63FFEA BAFC46E0 3DC419EE 714B9ABD
      144A21E3 3E54C103 FF47FAF1 412FE5C4 59ACD1FE FD72356B C8DC04C3 E2EDF275 45954C
      quit
    username <removed secret 5 <removed>
    ip ssh maxstartups 10
    ip ssh time-out 60
    ip ssh authentication-retries 2
    ip ssh port 2226 rotary 1
    ip ssh version 2
    class-map match-all Zuri-YouTube-Class
    match access-group name NAT-Pool-Zuri-WLAN
    match protocol http host "*youtube.com*"
    policy-map PMAP-QOS-VTI-IN
      description QOS FOR TU0
    class class-default
      shape peak 1512000
    policy-map PMAP-QOS-VTI-OUT
      description QOS FOR TU0
    class class-default
      shape peak 512000
    crypto isakmp policy 1
    encr aes 256
    authentication pre-share
    group 5
    lifetime 43200
    crypto isakmp key 6 <removed> address <removed>
    crypto isakmp invalid-spi-recovery
    crypto isakmp keepalive 10 5 periodic
    crypto ipsec transform-set EDGE-TS ah-sha-hmac esp-aes 256
    crypto ipsec profile EDGE
    set security-association lifetime kilobytes 256000
    set transform-set EDGE-TS
    set pfs group5
    interface Loopback0
    no ip address
    interface Tunnel0
    description "VTI Link"
    bandwidth 4000
    ip address 172.20.0.2 255.255.255.0
    ip mtu 1400
    ip nbar protocol-discovery
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1360
    ip ospf authentication message-digest
    ip ospf message-digest-key 1 md5 7 12090011003E5A0C0F186E752220211B4A
    keepalive 10 5
    tunnel source FastEthernet0/0
    tunnel destination <removed>
    tunnel mode ipsec ipv4
    tunnel path-mtu-discovery
    tunnel protection ipsec profile EDGE
    service-policy output PMAP-QOS-VTI-OUT
    hold-queue 75 out
    interface FastEthernet0/0
    description "Link to ISP"
    bandwidth 4000
    ip address dhcp
    ip access-group ACL-OUTSIDE-IN in
    no ip proxy-arp
    ip nbar protocol-discovery
    ip nat outside
    ip inspect fa0/0_inspect_ou out
    ip virtual-reassembly
    ip ospf cost 1
    duplex auto
    speed auto
    no keepalive
    no cdp enable
    interface FastEthernet0/1
    description "Link to LAN"
    ip address 172.16.0.1 255.255.255.248
    ip access-group ACL-INSIDE-IN in
    no ip proxy-arp
    ip nbar protocol-discovery
    ip nat inside
    ip virtual-reassembly
    ip ospf cost 1
    ip ospf priority 255
    duplex auto
    speed auto
    no keepalive
    router ospf 1
    log-adjacency-changes
    redistribute static subnets
    passive-interface default
    no passive-interface Tunnel0
    network 172.20.0.0 0.0.0.3 area 0
    ip forward-protocol nd
    ip route 10.0.0.0 255.0.0.0 Null0 name "Class A Private"
    ip route 172.16.0.0 255.240.0.0 Null0 name "Class B Private"
    ip route 172.17.0.0 255.255.0.0 FastEthernet0/1 172.16.0.2 name "Home WLAN"
    ip route 172.19.73.31 255.255.255.255 Null0
    ip route 172.27.0.0 255.255.0.0 Tunnel0 172.20.0.1 name "IPsec GRE Tunnel"
    ip route 192.168.0.0 255.255.0.0 Null0 name "Class C Private"
    ip route 192.168.0.0 255.255.255.0 Tunnel0 172.20.0.1 name "VLAN 70"
    ip route 192.168.100.1 255.255.255.255 FastEthernet0/0 70.162.0.1 permanent name "CABLE MODEM MANAGEMENT"
    ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 dhcp 253
    ip dns server
    no ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip nat translation tcp-timeout 300
    ip nat translation udp-timeout 120
    ip nat translation max-entries 2048
    ip nat inside source list ACL-NAT-172.16.0.0/29 interface FastEthernet0/0 overload
    ip nat inside source list ACL-NAT-MANAGEMENT interface FastEthernet0/0 overload
    ip nat inside source static tcp 172.16.0.4 22 interface FastEthernet0/0 2227
    ip nat inside source static tcp 172.16.0.5 3389 interface FastEthernet0/0 3391
    ip nat inside source static tcp 172.16.0.3 3389 interface FastEthernet0/0 3390
    ip nat inside source static tcp 172.16.0.4 80 interface FastEthernet0/0 8084
    ip access-list standard ACL-ACCESS-QUIET
    permit 216.161.180.16
    permit 172.16.0.0 0.1.255.255
    permit 172.27.0.0 0.0.127.255
    permit 172.20.0.0 0.0.0.3
    ip access-list standard ACL-NAT-172.16.0.0/29
    permit 172.16.0.0 0.0.0.7
    ip access-list standard ACL-NAT-172.17.0.0/24
    permit 172.17.0.0 0.0.0.255
    ip access-list standard ACL-NAT-172.17.1.0/24
    permit 172.17.1.0 0.0.0.255
    ip access-list standard ACL-SNMP
    permit 172.16.0.4
    ip access-list extended ACL-CRY-MAP
    ip access-list extended ACL-INSIDE-IN
    deny   ip host 172.16.0.2 172.27.0.0 0.0.127.255
    deny   ip host 172.16.0.2 172.20.0.0 0.0.0.3
    permit ip 172.17.0.0 0.0.0.255 any
    permit ip 172.16.0.0 0.0.0.7 any
    permit ip 172.17.1.0 0.0.0.255 any
    ip access-list extended ACL-NAT-MANAGEMENT
    permit tcp host 172.27.10.11 eq 3389 host 72.166.77.196
    ip access-list extended ACL-OUTSIDE-IN
    deny   ip 10.0.0.0 0.255.255.255 any
    deny   ip 172.16.0.0 0.15.255.255 any
    deny   ip 192.168.0.0 0.0.255.255 any
    permit tcp any any range 3390 3391
    permit udp any any eq bootpc
    permit udp any any eq bootps
    permit tcp any any range 2226 2228
    permit tcp any any range 8081 8084
    permit icmp any any echo
    permit icmp any any net-unreachable
    permit icmp any any host-unreachable
    permit icmp any any port-unreachable
    permit icmp any any parameter-problem
    permit icmp any any packet-too-big
    permit icmp any any administratively-prohibited
    permit icmp any any source-quench
    permit icmp any any ttl-exceeded
    deny   icmp any any
    deny   ip any any
    ip access-list log-update threshold 10
    logging history informational
    logging trap debugging
    logging 172.17.228.17
    logging 172.17.228.10
    control-plane
    line con 0
    exec-timeout 15 0
    privilege level 15
    logging synchronous
    login authentication AUTH-LOCAL
    line aux 0
    login authentication AUTH-LOCAL
    line vty 0 4
    exec-timeout 60 0
    privilege level 15
    logging synchronous
    login authentication AUTH-LOCAL
    rotary 1
    transport input ssh
    scheduler allocate 20000 1000
    ntp clock-period 17178311
    ntp source FastEthernet0/0
    ntp server 148.167.132.201
    end

    Hi Matt,
    Try adding below line
    ip access-list extended ACL-OUTSIDE-IN
    permit udp any eq bootpc any eq bootps
    Regards
    Najaf
    Please rate when applicable or helpful !!!

  • Bug or feature? - DHCP with static entries gives "wrong" DNS?

    Server 10.4.8 G4 Xserve
    Bonded interface (built-in and PCI, LACP)
    DHCP, DNS and "more" running.
    DHCP static IP entry (?) windows (and mac?) machines get their DNS IP from the server DNS setting from Network config, not from DHCP config ???
    Machines with no static entry get the DNS IP from the DHCP server setting.
    If you use 127.0.0.1 as the nameserver setting in Network config the static clients obviuosly can't lookup names. I had to use the "hostname IP" instead.

    Hi,
    I did not quiet understand what you mean. It looks completely visible for me.
    You did not set scene width and height so maybe that is reason why it was not visible.
    This code works for me:
    package playground;
    import javafx.application.Application;
    import javafx.scene.Group;
    import javafx.scene.Scene;
    import javafx.scene.control.Label;
    import javafx.scene.effect.Reflection;
    import javafx.scene.layout.BorderPane;
    import javafx.scene.text.Font;
    import javafx.stage.Stage;
    public class LayoutLabel extends Application {
        @Override
        public void start(Stage stage) throws Exception {
            stage.setTitle("Test JFX");
            stage.setScene(createScene());
            stage.setVisible(true);
        private Scene createScene() {
            Label label = new Label("Hello world!");
            label.setFont(new Font(24));
            Reflection reflection = new Reflection();
            reflection.setFraction(1.0);
            reflection.setBottomOpacity(1.0);
            reflection.setTopOffset(0.0);
            label.setEffect(reflection);
    //        Group pane = new Group();
            BorderPane pane = new BorderPane();
            pane.setCenter(label);
    //        pane.setTop(label);
    //        pane.setBottom(label);
    //        Pane pane = new StackPane();
    //        Pane pane = new FlowPane();
    //        Pane pane = new HBox();
    //        pane.getChildren().add(label);
            Scene scene = new Scene(pane, 200,200); // changes to 200 200 maybe that is reason why it does not show
            return scene;
        public static void main(String[] args) {
            Application.launch(args);
    }

  • Unable to get IP address from DHCP

    hi all,
    I have a AP1131 which cannot get IP from DHCP server. I have tried to configure static IP address and controller IP by lwapp command and the AP can successfully joined the controller. However, after I changed it to DHCP in WLC, it cannot get IP address and all lwapp config is gone. It cannot join the controller anymore only after I reset it and configure a static IP for it. The following error message appears after I changed it to DHCP in the WLC:
    *Mar 7 08:44:36.511: RESETTING THE STATIC IP ADDRESS: LWAPP goes back to discovery
    %WIDS-6-DISABLED: IDS Signature is removed and disabled.
    %LWAPP-5-CHANGED: LWAPP changed state to DISCOVERY
    %LWAPP-5-CHANGED: LWAPP changed state to DISCOVERY
    %LINK-3-UPDOWN: Interface Dot11Radio0, changed state to up
    %LINK-3-UPDOWN: Interface Dot11Radio1, changed state to up
    %LWAPP-3-CLIENTERRORLOG: Config Command: error verifying sequence number
    %LINK-5-CHANGED: Interface Dot11Radio1, changed state to reset
    %LINK-5-CHANGED: Interface Dot11Radio0, changed state to reset
    %LWAPP-3-CLIENTERRORLOG: Config Command: error verifying sequence number
    %LWAPP-3-CLIENTERRORLOG: Config Command: error verifying sequence number
    %LWAPP-3-CLIENTERRORLOG: Config Command: error verifying sequence number
    %LWAPP-3-CLIENTERRORLOG: Config Command: error verifying sequence number
    %LWAPP-3-CLIENTERRORLOG: Config Command: error verifying sequence number
    Any expert has some idea on it?
    Thanks.

    Is that AP on the same subnet as the other AP's? The thing is, when you configure the AP with static information, you say the AP is able to join the WLC. This means that there is no issue with the AP. Now when you set the AP to use DHCP and not static, the AP does not obtain a DHCP address? Is that correct? If you have more than one AP on the same switch and on the same vlan, and only one has an issue, then maybe reset that AP to default and see if that fixes it. I'm also assuming that the vlan is being forwarded and you have enough dhcp address in the scope.

  • Combined dhcp and static ip?

    I'd like to be able to specify a static ip address and get the remaining stuff (dns, gateway, and whatever) from dhcp. It this possible?

    lumpynose wrote:
    wudu wrote:
    I know that there is an option for network-manager to get only the addres from DHCP but I think there's nothing for what you want.
    I'm not sure what you want to do. Do you have changing DNS servers and gateways?
    If you have control over the DHCP server you could do that by static DHCP (your pc gets the same address every time based on the MAC address). If the DHCP server is running on a router you often don't have this as option (directly).
    Other possibility is to get everything from DHCP and then change your IP address manually or with a script.
    Changing the ip address afterwards is an idea.  I've been with my ISP for a long time and they have changed the addresses of the DNS servers.
    Being able to specify just a static network interface address seems like a useful thing to me in a home environment; I want a static address so I can easily ssh to the machine, and the other stuff, DNS, gateway, etc. I can let DHCP set up.
    Are you saying that you want to set a static Public IP address on the interface that connects to your home ISP? Like, your ISP changes your public IP address which makes it hard to ssh back home.
    If this is the problem you are trying to solve, you would be better off just buying like a .info domain for $2 and setting up Dynamic DNS. I find Hurricane Electric to be a good DNS host. They will let you add Dynamic A records. Then you just set a cron job to update the dns records like every 30min's to be sure it is always correct.
    With this promo code from the Linux Action Show you will save 35% off your order of the domain.
    http://www.godaddy.com/?isc=go35off3
    Free DNS host (these guys are a global Internet backbone provider)
    https://dns.he.net
    Last edited by hunterthomson (2013-03-24 11:00:37)

  • [Solved] Two ethernet ports (dhcp and static)

    For various reasons I connect to the internet as follows:
    Computer --> eth0 --> Linksys Router --> Aztech Modem/Router --> Internet
    From time to time I need to access the Aztech. Usually I change the eth0 cable connecting to the Linksys to the Aztech. And restart networking. Access the Aztech. Then change the cable from Aztech to Linksys. Restart network.                 
    In Debian (to avoid this cable changing), what I did was to also have a cable as follows:
    Computer --> eth1 --> Aztech Modem/Router
    eth1 is a static configuration. The debian /etc/network/interfaces file looks like
    auto eth0
    iface eth0 inet dhcp
    auto eth1
    iface eth1 inet static
    address 10.0.0.3
    netmask 255.255.255.0
    So in Debian I plug a cable into eth1 (from the Aztech). I can then access the Aztech without it interfering with resolv.conf so I can still browse the internet via eth0.                                                     
    I have tried the following in ArchLinux:
    HOSTNAME="milomak-arch"
    eth0="dhcp"
    INTERFACES=(eth0)
    eth1="eth1 10.0.0.1 netmask 255.255.255.0"
    INTERFACES=(eth1)
    gateway="default gw 192.168.1.1 10.0.02"
    ROUTES=(!gateway)
    However when I boot this is what I see
    # ifconfig
    eth1 Link encap:Ethernet HWaddr 00:24:8C:52:DC:5F
    inet addr:10.0.0.1 Bcast:10.0.0.255 Mask:255.255.255.0
    inet6 addr: fe80::224:8cff:fe52:dc5f/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:468 (468.0 b)
    Interrupt:17
    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:24 errors:0 dropped:0 overruns:0 frame:0
    TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:1280 (1.2 Kb) TX bytes:1280 (1.2 Kb)
    what am i missing?
    Last edited by milomak (2009-11-21 10:35:16)

    Put both interfaces in the INTERFACES= array.
    /etc/rc.conf includes this detail, with a slightly different wording i.e.
    # Interfaces to start at boot-up (in this order)
    # Declare each interface then list in INTERFACES

  • WRT54G2 v1 (1.0.03) Does not get IP from DHCP on WAN

    I use cable internet connection (dynamic IP + PPTP VPN) .When cable plugged directly to  network adapter of computer  , all works good - computer gets IP -address and connect to VPN-server. If I connect cable to router's WAN port - I see in status tab of configuration page  that router wan interface can't get an ip-addres (0.0.0.0 in all fields) and because can't connect to VPN
    What's wrong?
    P.S  Do anyone have a firmware v 1.0.02 for it? There are 1.0.03 only at linksys store ...
    Message Edited by Vasyukov on 04-04-2009 09:31 PM

    Please explain in details, what settings you have set on your router. Whats the Internet Connection Type (DHCP / PPTP / STATIC IP).
    As the Latest Firmware for this router is available. You can Download 1.7 MB, The firmware version is Ver.1.0.03. 
    Follow these steps to upgrade the firmware on the device : -
    Open an Internet Explorer browser page on a computer hard wired to the router...
    In the address bar type - 192.168.1.1...Leave the username blank & in password use admin in lower case...
    Click on the 'Administration' tab- Then click on the 'Firmware Upgrade' sub tab- Here click on 'Browse' and browse the .bin firmware file and click on "Upgrade"...
    Wait for few seconds until it shows that "Upgrade is successful"  After the firmware upgrade, click on "Reboot" and you will be returned back to the same page OR it will say "Page cannot be displayed".
    Now reset your router :
    Press and hold the reset button for 30 seconds...Release the reset button...Unplug the power cable from your router, wait for 30 seconds and re-connect the power cable...Now re-configure your router...

  • Problem for configuring DHCP IPV6 on my router

    Hi everybody,
    I try to test DHCP IPV6.
    My topologie is very simple :
     CustomerA <--------------------------->R_IPV6
     - Customer is Linux debian 
    - Router is 7200 >>> Version 12.4(25f)
    I read the documentation 
    http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipv6/configuration/12-4t/ipv6-12-4t-book/ip6-dhcp.html
    I try to configured server DHCP IPV6, but I don't see all command !!!!
    router_A(config)#ipv6 dhcp pool client_siteA
    router_A(config-dhcp)#?
    IPv6 DHCP configuration commands:
      default            Set a command to its defaults
      dns-server         DNS servers
      domain-name        Domain name to complete unqualified host names
      exit               Exit from DHCPv6 configuration mode
      no                 Negate a command or set its defaults
      prefix-delegation  IPv6 prefix delegation
      sip                SIP Servers options
    router_A(config-dhcp)#
    I don't configured the  address prefix ???
    Why ?
    Bad version ?
    My configuration
    router_A#sh run
    Building configuration...
    Current configuration : 1297 bytes
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname router_A
    boot-start-marker
    boot-end-marker
    no aaa new-model
    ip cef
    no ip domain lookup
    ip domain name lab.local
    ipv6 unicast-routing
    ipv6 cef
    ipv6 dhcp pool client_siteA
     dns-server 2001:4860:4860::8888
     dns-server 2001:4860:4860::4444
     domain-name nantes.net
    interface FastEthernet0/0
     no ip address
     duplex auto
     speed auto
     ipv6 address FC00:1::1/64
     ipv6 ospf 1 area 0
    interface FastEthernet0/1
     no ip address
     shutdown
     duplex auto
     speed auto
    interface FastEthernet1/0
     description Site-Local
     no ip address
     duplex auto
     speed auto
     ipv6 address FC00::1/64
     ipv6 nd managed-config-flag
     ipv6 nd other-config-flag
     ipv6 dhcp server client_siteA
    interface FastEthernet1/1
     no ip address
     shutdown
     duplex auto
     speed auto
    ip forward-protocol nd
    no ip http server
    ipv6 router ospf 1
     router-id 1.1.1.1
     log-adjacency-changes
     redistribute connected
    control-plane
    line con 0
     exec-timeout 0 0
     privilege level 15
     logging synchronous
     escape-character 3
     stopbits 1
    line aux 0
     exec-timeout 0 0
     privilege level 15
     logging synchronous
     stopbits 1
    line vty 0 4
     login
    end

    It's OK with :
    interface FastEthernet1/0
     description Site-Local
     no ip address
     duplex auto
     speed auto
     ipv6 address FC00::1/64
     ipv6 nd managed-config-flag
     ipv6 nd other-config-flag
     ipv6 dhcp server client_siteA

  • IPv6 Static address

    I have a Swann Communication security camera system with their DVR8-4000 hooked to an IPv4 router, connected to the Internet using the new HughesNet Gen4 service. 
    The Swann DVR wired to my router requires a static IP address.  HughesNet Gen4 is implemented with IPv6 and I am told that it does not accommodate an IPv4 type static address.
    I have discussed the issue with both company’s technical support.  HughesNet Gen4 reps recognize the issue and may support static addressing in the future, but not now.  Swann reps will not modify their implementation because of the relatively small Gen4 market.  The Swann rep suggested that replacing my IPv4 router with an IPv6 router might resolve the “static IP address” issue.
    I am looking at several Linksys IPv6 routers including the EA4500 SMART WiFi Wireless Router N900, but know too little about IPv4, IPv6 and router/static addressing to proceed unassisted.
    I will be grateful for any guidance; including 1) can I implement a static address with an Linksys IPv6 router cdonnected to Gen4?  2) Which Linksys routers offer IPv6 support?  3) How does one go about setting an IPv6 static address using HughesNet Gen4 on a Linksys router?

    For your 1st question, the EA4500 does support manual ipv6 but only for 6rd tunneling. For your 2nd question, E4200 v1&2 and the EA series routers support ipv6. Last, for your 3rd question; as long as you have the 6rd tunnel settings from your ISP then you will be able manually set ipv6 on your router.

Maybe you are looking for