Authenticate users via email

This is the problem:
i want to send a URL to visited by a user, so that after doing that, he's authenticated by the system.
This is like some of most used web phorum work.
How can i solve this problem?
where can i find examples?
I think the problem is to generate dynamic URLs, one per each user to be authenticated...but maybe there are easier solutions..
thanks!

why not just email them something like the forum link here?
like:
http://www.cometomysite?reply=true
then when the user clicks that link they'll be taken to the site on that page check the value of reply, if it's not there or not equal to true don't let them in. basically it's better to use something other then true or false, if you want send them some bizarre word or number. basically you will be using the URL to authenticate the user. here's something on it:
http://javaboutique.internet.com/tutorials/JSP/part04/
try searching on google for url writing with jsp servlets.

Similar Messages

  • Adding  prompts dynamically and then send the results to users via email

    Hi,
    We have to schedule the reports for auto delivery to users at a specific time period. Please, tell me the mechanism to schedule them and how to assign prompt values to them. Currently, the reports are run by users by selecting prompts from the dashboard. If we schedule them, we will have to add some of these prompts dynamically and then send the results to users via email.
    Thanks in advance!

    Hi,
    I haven't tested it myself...but may be the following steps can help you.
    Fill some session variables depending on the the name of the user who logs in (this can be done easily be creating different session variables and put some executing order in it)
    Then you use these session variables as default values for your prompts. So the report will be executed making use of this default values.
    And by scheduling your ibot..you can send it by mail.
    I don't know if it's this what you're looking for...probably you have to base your prompt values depending on the users that are selected in your ibot?
    Hope it can help y ou in some way or another...
    KR,
    A

  • Report run in background, attachment needs to be sent to user via email

    Hi all,
    we have a PDF solution which allows the system to send a PDF document as attachment via email to the recipient, all one needs to do is type in recipient email to a predefined PDF printer.
    What i need is a similar solution but instead of PDF it has to be an Excel file attached to email.
    The enduser does not have authorization to use SM36.
    Searching the Web (and with help from our Basis team) i have found several ideas but not sure as it would mean coding programs and so on.
    Is there an easier way?
    regards
    RM

    Hi all,
    we have a PDF solution which allows the system to send a PDF document as attachment via email to the recipient, all one needs to do is type in recipient email to a predefined PDF printer.
    What i need is a similar solution but instead of PDF it has to be an Excel file attached to email.
    The enduser does not have authorization to use SM36.
    Searching the Web (and with help from our Basis team) i have found several ideas but not sure as it would mean coding programs and so on.
    Is there an easier way?
    regards
    RM

  • Automatic scheduling of report and send the output  to user via email

    Good Morning,
    Please i need to scheduled report and send the output via email in Discoverer . Please can someone assist in how to achieve this ?

    Hi,
    You cannot schedule and email a Discoverer report using standard Discoverer scheduling. You have to use a third party scheduler and Discoverer Desktop running on a windows PC.
    This presentation has some more details on how to do this.
    Rod West

  • Pushing reports to user via email

    Hi,My users would like to have an alert system, which runs a report on Essbase, e.g. daily, and if the sales is below certain threshold, it sends the report or some kind of alert messages to user's email.Would either Analyzer or Essbase offer this capability? If so, how? I couldn't find it anywhere in the documentation. Are there any tools which offers this capability?Thanks in advance for any response.Sam

    You could do it in Excel with a VBA programme to run a retrieve and send an e-mail from within Excel (using Workbook.SendMail) depending on the result. Make the VBA code automatically on opening the sheet, and set up a scheduled task to open the workbook at a particular time.I do similar stuff for overnight processing.

  • When Matching Users Via Email, Changing Email Address Does Not Change Login

    Well, the subject pretty much says it all, but here're some examples of what's going on:
    Initial Data
    - Create 2 Business Partners in SAP, C1 and C2.
    - Create 2 Contact Employees in SAP, Adam with email adam at eden.org in C1 and Eve with no email in C2.
    Synch
    - Run Initial Synch followed by Standard Synch (for good measure).
    - Web Tools gets user Adam with username adam at eden.org.
    - Web Tools gets user Eve with username 2, the unique key for SAP's Contact Employee.
    Data Change In SAP
    - Adam's email is removed.
    - Eve's email is populated with eve at eden.org.
    Resynch
    - Run Standard Synch.
    - Web Tools changes both email addresses, with Adam's being erased and Eve's becoming eve at eden.org.
    - Web Tools does not change the UserID, leaving Adam's as adam at eden.org and Eve's as 2.
    That last bullet is the big problem: if a user changes an email address, the username doesn't change. Is there any way to change this across the board, or perhaps even force users to login via their current email address?

    Also, there is a field in the Users table called EmailLogin. I have tried without success to change this field so that the user would use this field to login instead of the UserID, but have been unsuccessful in getting it to work.
    As an alternative, the login control in /plugins/loginblock.ascx contains, as a portion, the following code:
        protected void loginMain_LoggedIn(object sender, EventArgs e) {
            NPUser user = new NPUser(loginMain.UserName);
            ((NPBasePage)Page).Login(user.UserID, user.AccountID, false);
    Wouldn't it be simple to do the following?
        protected void GetUserIDFromDBByEmail(string email) {
            string userid;
            System.Data.SqlClient.SqlConnection conn = new System.Data.SqlClient.SqlConnection();
            System.Data.SqlClient.SqlCommand cmd = new System.Data.SqlClient.SqlCommand(conn, "SELECT Users.UserID FROM Users WHERE Users.Email='" + email.Replace("'", "''") + "'");
            userid = (string)cmd.ExecuteScalar();
            cmd.Connection.Close();
            conn.Close();
        protected void loginMain_LoggedIn(object sender, EventArgs e) {
            string userid;
            // Though we're passing the "username" from the form,
            // we know that we're expecting the email to be in it
            userid = GetUserIDFromDBByEmail(loginMain.UserName);
            NPUser user = new NPUser(userid);
            ((NPBasePage)Page).Login(user.UserID, user.AccountID, false);
    Again, the benefit to this is that you can synch using the Internal B1 Contact Code, which will remain constant and unique, and have the availability to change the way the user logs in by modifying the email address. Of course, email addresses would have to remain unique as well, but that's an easy enough thing to check for.

  • Send Invoice to multiple user via email.

    Hi,
    We are using the output type external send. But the standard PO process will send email to only 1 recipient. The email will be taken from the customer master where email is flagged as Standard.
    Is there any other way (or any user exit) to send invoice to a multiple recipient (TO and COPY-TO) maintained in customer master?
    Appreciate your input.
    Thanks

    Hi Kiran
    If you have output type maintained in your system and you want to send it to multiple people then all you have to do is include the partner functions in the output type in transaction NACE or V/30. The system will automatically copy the email addresses from the partner profiles and mail will be sent...
    I hope it helps.
    Though if it a certain set of ppl that the mail has to be sent to every time a PO is raised then you will have to take the help of your ABAPer.

  • HT201441 i think apple should unmask the id so present user has a chance to contact older user via email

    in my openion apple should unmask the id for those users whos phones are not in stolen mode,only ther phone r locked when they update or restore.millions of people around the globe facing similar problem including me while they didnt know any info about previous user.perhaps its sound great that a tuff and unbreakable lock invented by apple for theft reason but this floud takes away those people also who are innocent and uneducated too.well users of iphone are getting droper n droper day by day by this lock feature and they r making there way to andriod.

    You can Tell Apple at the link below.
    http://www.apple.com/feedback/

  • Irregular failure to authenticate OpenDirectory users via password-based ssh

    TL;DR - my Yosemite Open Directory server irregularly fails to properly authenticate users (via password-based ssh). 
    I recently moved an Open Directory server from an Xserve running 10.6 to a new Mini running 10.10.  I archived the OD config on the Xserve and then took it offline.  Then I brought the Mini online using the same hostname/IP address, created a new OD master using the archived configuration.  Everything seemed to work well, however sometimes the server will not authenticate users via password when logging in with ssh/sftp/scp.  This is also true of a few OS X machines that bind to the OD server (i.e. they usually authenticate users properly, but sometimes fail for no discernable reason). 
    The failures are only for password authentication using ssh.  Other mechanisms do not exhibit the auth failures.  For instance, AFP and SMB user auth never fails (with proper credentials).  Nor do users to a FileMaker Server machine that authenticate via the OD server have problems.  Public key based ssh authentication never fails.  Local accounts (non-OD, aka "Local Network Accounts") also do not fail using password-based authentication.
    The failures are irregular.  The only pattern that I can find at all is that sometimes when the failures start happening, they keep happening continuously until...at some point they work properly again.  That is, they may fail from 11:15 am to 2:01 pm, and if so, then all of them fail in that time range.  Sometimes that time range lasts seconds, sometimes it lasts hours.
    The time range failure pattern is host specific.  For instance, if password authentication is failing on the main OD server, authentication may be fine on the other bound machines.  If authentication is failing on one of the bound machines, then it may be fine on all others and fine on the OD server itself.
    The failure pattern does not seem to correlate to any other events or activity on the server (even remotely).  CPU utilization never gets above about 15%.  Memory utilization is similarly very low.  Network traffic is occasionally high, but it does not seem in any way related to the auth failures.  There are not other log messages that occur before or after the failures with any consistency.
    I've been monitoring the auth failures by attempting to login to the OD server and two other bound hosts once per minute so that I can tell when the auth is failing (before getting calls from the users). 
    The adaptive firewall is not running on the OD server.  Nor is any other firewall.
    Below are a comparison of the system.log entries for a failed and successful auth (I've stripped out those lines that are identical in both instances).  The log entries have been sanatized as described.
    Rebooting the OD server does not affect the bound clients' authentication.  Rebooting the OD server is problematic, and I cannot do it often.  When I do, sometimes failures start soon after reboot, and sometimes that don't come back for many hours - again, no discernable pattern.
    If anyone has any ideas what I can do to discover the source of this problem and come up with a solution, I'd very much appreciate it.  Note that I'm aware that I can export all users and group and reconstruct a new, clean OD master, but without the ability to save the passwords, this becomes a large logisitcal problem, and I'm saving it as a last resort (particularly since if it doesn't solve my problem, I will have inconvenienced many users and be right back in the same place).
    Thanks for reading.
    First failure:
        Feb 11 00:00:20 odserver.myorg.gov kdc[67]: TGS-REQ [email protected] from 127.0.0.1:65373 for host/[email protected] [canonicalize, forwardable]
        Feb 11 00:00:20 odserver.myorg.gov opendirectoryd[67268]: GSSAPI Error:  Miscellaneous failure (see text (unable to reach any KDC in realm ODSERVER.MYORG.GOV, tried 2 KDCs (negative cache))
        Feb 11 00:00:20 odserver.myorg.gov sshd[72974]: error: PAM: authentication error for myusername from clienthost.myorg.gov via 10.50.50.50
        Feb 11 00:00:20 odserver.myorg.gov sshd[72974]: Connection closed by 10.50.50.99 [preauth]
    Now successful auth:
        Feb 11 01:03:20 odserver.myorg.gov kdc[67]: TGS-REQ [email protected] from 127.0.0.1:63978 for host/[email protected] [canonicalize, forwardable]
        Feb 11 01:03:20 odserver.myorg.gov kdc[67]: TGS-REQ [email protected] from 127.0.0.1:62346 for ldap/[email protected] [canonicalize, forwardable]
        Feb 11 01:03:20 odserver.myorg.gov sshd[73786]: Accepted keyboard-interactive/pam for myusername from 10.50.50.99 port 53361 ssh2
        Feb 11 01:03:20 odserver.myorg.gov NetAuthSysAgent[73789]: GetStatus: connecting to self not allowed
       Feb 11 01:03:20 odserver.myorg.gov NetAuthSysAgent[73789]: ERROR: AFP_GetServerInfo - connect failed 62
    I've sanitized the entries as follows, replacing...
    My username by myusername
    The ssh source host IP address by 10.50.50.99
    The ssh source hostname by clienthost.myorg.gov
    The server hostname by odserver.myorg.gov
    The server hostname (in caps) by ODSERVER.MYORG.GOV
    The server IP address by 10.50.50.50

    Hello James,
    I have not had a chance to look for the Router configuration document, however, for one of my certificate exams I did configure Authentication Proxy on an IOS router. The config for that lab was:
    aaa new-model
    aaa authentication login default group tacacs+ local
    aaa authorization auth-proxy default group tacacs+ local
    aaa session-id common
    ip auth-proxy name AUTHPROXY http inactivity-time 60
    interface FastEthernet0/0
    ip address 192.168.250.19 255.255.255.0
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    interface FastEthernet0/1
    ip address 192.168.200.120 255.255.255.0
    ip access-group 110 in
    ip nat inside
    ip virtual-reassembly
    ip auth-proxy AUTHPROXY
    duplex auto
    speed auto
    ip route 0.0.0.0 0.0.0.0 192.168.250.1
    ip http server
    ip http authentication aaa
    no ip http secure-server
    ip nat inside source list nat interface FastEthernet0/0 overload
    ip access-list extended nat
    permit ip 192.168.200.0 0.0.0.255 any
    access-list 110 permit ip any any
    tacacs-server host 192.168.250.20
    tacacs-server key cisco123
    end
    Please check if the commands are supported on your router as well.
    If this ws helpful please rate.
    Regards.

  • Send report via email as xls file.

    Hello from Spain,
    Sorry if this is not the correct forum. It's both a forms and reports question, but I think it fits better in the reports forum. I have queried into the forums for similar questions and found some threads without any replies around this same issue. I wish I am lucky today.
    I have developed some web forms which generate pdf and txt reports. The latter ones make use of desformat=delimiteddata when calling the reports. They run fine. I have also developed one form which suscribes those reports to email addresses. To do so, I am setting those email addresses in the DESNAME reports parameter and setting DESTYPE parameter as MAIL. They arrive as an attachment with pdf or txt extensions.
    Now, I am required to deliver those reports as xls files. I have been reading that desformat=spreadsheet would allow me to do so (as well as formatting the reports and make them look "cuter" than by using just delimiteddata), but have been unable to do it so far. When setting desformat=spreadsheet, reports are sent via email as html attachments, and when they are opened they look awful. Is there any way I can do this? It shouldn't be a too big deal, but I feel completely unable.
    Thank you,
    Fernando G.

    Hi,
    Please check the following forum thread that may help --> Re: Generate report in Excel and send to user via email.
    Thanks, RZ

  • How to create an excel report and send it via email using a BPEL process ?

    Hi Experts,
    I have a requirement to develop a xl report based the data in the DB table. I will have to query the list of records entered / processed during previous day, generated the xl based report and send to users via email.
    I talked to one the experts, he asked me to use the following Adapter and BPEL activities to accomplish it.
                   DBAdapter --> {BPEL  process} --> Java Embedding --> Email Activity.
    Can someone please help me to pass the information retrieved by DBAdapter to Java Embedding and then to email import? I have created DBAdapter and Java Embedding. I don't know, how to retrieve the data read / sent by DBAdapter using Java Embedding. Also please help me to pass the xl attachment to Email Activity.
    Thanks for your help in advance!
    Thanks,
    Harisudhan Selvaraj

    I would suggest something like:
    DBAdapter --> Bpel Process --> File Adapter --> write file to location (you can write in csv which can be imported into xls)
    Read Location --> FileAdapter --> Bpel Process --> Email Activity
    Regards,
    Anshul

  • Idoc error via email

    Hi Guys,
    is it possible to send the IDOC errors to the business User via email.
    1. I Know we can use workflow to send email
    is there any other way not doing Abap coding.
    Regards,
    Kumar

    closed

  • How send PO display as link via email

    Hello,
    I got requirement. whenever a new PO is getting created, we  need to notiyfy list of users via email. email content should have a link to PO display. so whenever user logs into his outlook/lotus notes and clicks on the PO display link, it should take him to corresponing PO.
    How to acheive this via email. please help me out with some solutions.
    PS:
    its not a action(workitem), its via email.
    Regards,
    paris
    014 260 3230

    Purvesh,
    my requirement is just send a link ( PO display ) as mail..
    ex:
    hello Arun,
    please click on the PO number to view the PO .
    180000023
    Once user clicks on the link, it should take him to R/3 system. basically it should call ME23 transaction from outlook.
    Hope this clears you my requirement?

  • How do I received the filled out form via email? After the user hits SUBMIT, I'd like to receive the filled out form via email.

    How do I received the filled out form via email? After the user hits SUBMIT, I'd like to receive the filled out form via email.

    Formscentral doesn't support direct delivery of filled forms via email at this time. You can however use Acrobat to add an email link to a form instead of a submit button. In this way the PDF will be returned to the email of your choice.
    Andrew

  • HT201407 I am Hamza of Iraq as possible understand me,  bought the iPhone from the owner of the device user and I do not know him and have worked formate device to show white screen and please me to activate the device via email and password Please help m

    I am Hamza of Iraq as possible understand me,  bought the iPhone from the owner of the device user and I do not know him and have worked formate device to show white screen and please me to activate the device via email and password Please help me I am po

    You need the Apple ID and password that was originally used to set up the device. Ask the seller to give it to you. If the seller is unable or unwilling to provide the information, the Phone is probably stolen. There is nothing you can do.

Maybe you are looking for

  • Popup in pruchase order while saving

    Hi Gurus, I have checked in forum but didn't find any solution for my requirement, kindly help for resolving the issue, reqmt: I need a pop-up while saving the purchase order with some information text and two options (Yes/No), if i click on Yes syst

  • Characters inside content="" code disappears on saving .css

    If I open an existing css file with the code content=""; make some other changes and save the content it disappears. My guess is that this is some kind of language/character/utf related setting? I only have this problem in Dreamweaver CC, not in old

  • Can I play a powerpc DVD play on 10.7.3

    I am up against the wall with a time sensitive issue. I am trying to learn the new Neonatal Resuscitative Procedures, 6th Edition, released this year. It has a modern DVD. Claims compatibility with most any computer out there. But not 10.7.3, that is

  • Displaying from an array

    hi my problem is i want to display an array of 120 characters in a format such as 6 numbers in a line and then the other six in a another line but each number has to have a spacing in between them. eg. 1 2 3 4 5 6 4 4 5 12 56 12 5 6 7 8 . . etc how d

  • How long should it take to turn on an ipod?

    I have an ipod touch (not the photo-taking type, the one that came out like a month before that. I think 3rd Generation? Software version 4.2.1). It is taking about 45-55 seconds to turn on. I have 1.33 available gb out of a capacity of 6.83 gb, if t