Unequal Load Balance on Etherchannel (L2/SW3400ME)

Hi, i have a problem with my L2 port-channel between 2 SW ME-3400-24TS-D (12.2(44)SE5), there is a unequal load balance and i don't know how to fixed. Should I change the load balance method?.
All four ports have the same config, except one (int fa0/1 on SW_2) that have this commands:
MAMANIVLN1P1IRA1#SH RUN INT FA0/1 | INC hold
 hold-queue 4096 in
 hold-queue 4096 out
Should i change this hold-queue config?
Here more outputs where you can see the diference, one link has 2mb and the other link has 60mb,, that's a big diference, i would like to know how to solve this:
SW_1#sh int fa0/9 | inc (Desc|rate)
  Description: !!!!!! HACIA SW_2 !!!!!
  Queueing strategy: fifo
  5 minute input rate 2088000 bits/sec, 2065 packets/sec
  5 minute output rate 25000 bits/sec, 46 packets/sec
SW_1#sh int fa0/10 | inc (Desc|rate)
  Description: PORTCHANNEL10 HACIA SW_2
  Queueing strategy: fifo
  5 minute input rate 1905000 bits/sec, 1948 packets/sec
  5 minute output rate 63348000 bits/sec, 6095 packets/sec
SW_2#sh int fa0/1 | inc (Desc|rate) 
  Description: Hacia SW_1_Fa0/9
  Queueing strategy: fifo
  30 second input rate 27000 bits/sec, 48 packets/sec
  30 second output rate 2385000 bits/sec, 1996 packets/sec
SW_2#sh int fa0/2 | inc (Desc|rate)
  Description: PORTCHANNEL10 HACIA SW_1
  Queueing strategy: fifo
  5 minute input rate 63567000 bits/sec, 6114 packets/sec
  5 minute output rate 1935000 bits/sec, 1976 packets/sec
more outputs...
SW_1#sh etherchannel load-balance 
EtherChannel Load-Balancing Configuration:
        src-mac
EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source MAC address
  IPv4: Source MAC address
SW_2#sh etherchannel load-balance 
EtherChannel Load-Balancing Configuration:
        src-mac
EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source MAC address
  IPv4: Source MAC address
SW_1#SH MAC ADDress-table INTerface po10 | inc Total
Total Mac Addresses for this criterion: 297
SW_2#SH MAC ADDress-table INTerface po10 | inc Total
Total Mac Addresses for this criterion: 66
In advance thanks for the help.

Normally it will fairly well balance the traffic . There is no way to make sure each channel is exactly the same utilization wise . You can look at how it is load balanced and make a change from say mac to ip address if it looks like you aren't getting the balance you want . It would be very rare that you are going to fill one port on the channel without filling the rest almost the same .Exceptions would be if you most of your traffic is headed to one place like a certain server , even then if you used ip addresses in both directions as the load balance I think it would balance out pretty good. If it got to that point where one link was almost filled you would have to think about adding another port to the channel . This is a real good page http://www.cisco.com/en/US/tech/tk389/tk213/technologies_tech_note09186a0080094714.shtml

Similar Messages

  • Unequal Load Balancing with EIGRP over 4 Wireless networks

    We are trying to load-balance on 4 interfaces that have unequal bandwidths. The setup looks like this
    8 Computers -> Empty Config Switch -> 3560 Router\Switch -> 4x Wireless Radios on different frequencies - networks -> 3560 Router\Switch->Empty Config Switch -> 8 Computers
    We have EIGRP setup and the bandwidths defined, and the routes are showing proper share counts, but once we start adding traffic to the network, they all jump on one of the links. The config and everything looks right, its just not working. I have tried switching to different cef algorithms. Removed the vlans . I made them equal cost and they did the same thing. Its like EIGRP does not want to load balance.
    When i did this config with static routes or as OSPF, it actually load balanced them, but I'm stuck with a 1:1 share ratio. If i could control the ratio, then that would be an acceptable solution.
    Any ideas on what could be causing this?
    Code:
    Routing entry for 192.168.104.0/24
      Known via "eigrp 10", distance 90, metric 13312, type internal
      Redistributing via eigrp 10
      Last update from 192.168.2.4 on Vlan2, 00:04:25 ago
      Routing Descriptor Blocks:
      * 192.168.9.4, from 192.168.9.4, 00:04:25 ago, via Vlan9
          Route metric is 51712, traffic share count is 31
          Total delay is 20 microseconds, minimum bandwidth is 50000 Kbit
          Reliability 255/255, minimum MTU 1500 bytes
          Loading 1/255, Hops 1
        192.168.5.4, from 192.168.5.4, 00:04:25 ago, via Vlan5
          Route metric is 13312, traffic share count is 120
          Total delay is 20 microseconds, minimum bandwidth is 200000 Kbit
          Reliability 255/255, minimum MTU 1500 bytes
          Loading 1/255, Hops 1
        192.168.3.4, from 192.168.3.4, 00:04:25 ago, via Vlan3
          Route metric is 26112, traffic share count is 61
          Total delay is 20 microseconds, minimum bandwidth is 100000 Kbit
          Reliability 255/255, minimum MTU 1500 bytes
          Loading 1/255, Hops 1
        192.168.2.4, from 192.168.2.4, 00:04:25 ago, via Vlan2
          Route metric is 13312, traffic share count is 120
          Total delay is 20 microseconds, minimum bandwidth is 200000 Kbit
          Reliability 255/255, minimum MTU 1500 bytes
          Loading 1/255, Hops 1
    3560_Switch_1#show int Fa 0/1 | inc packets/sec
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
    3560_Switch_1#show int Fa 0/2 | inc packets/sec
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
    3560_Switch_1#show int Fa 0/3 | inc packets/sec
      5 minute input rate 17111000 bits/sec, 2545 packets/sec
      5 minute output rate 13872000 bits/sec, 2251 packets/sec
    3560_Switch_1#show int Fa 0/4 | inc packets/sec
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
    3560_Switch_1#show ip cef exact-route 192.168.101.57 192.168.104.57
    192.168.101.57 -> 192.168.104.57 => IP adj out of Vlan5, addr 192.168.5.4
    Here is the config.
    Code:
    ip cef load-sharing algorithm universal 00123456
    interface FastEthernet0/1
    switchport access vlan 2
    bandwidth 200000
    delay 1
    spanning-tree portfast
    interface FastEthernet0/2
    switchport access vlan 3
    bandwidth 200000
    delay 1
    spanning-tree portfast
    interface FastEthernet0/3
    switchport access vlan 5
    bandwidth 200000
    delay 1
    spanning-tree portfast
    interface FastEthernet0/4
    switchport access vlan 9
    bandwidth 200000
    delay 1
    spanning-tree portfast
    interface GigabitEthernet0/1
    description USER PORT
    switchport access vlan 100
    spanning-tree portfast
    interface Vlan2
    bandwidth 200000
    ip address 192.168.2.1 255.255.255.0
    delay 1
    interface Vlan3
    bandwidth 100000
    ip address 192.168.3.1 255.255.255.0
    delay 1
    interface Vlan5
    bandwidth 200000
    ip address 192.168.5.1 255.255.255.0
    delay 1
    interface Vlan9
    bandwidth 50000
    ip address 192.168.9.1 255.255.255.0
    delay 1
    interface Vlan100
    description User Data
    ip address 192.168.101.1 255.255.255.0
    router eigrp 10
    maximum-paths 8
    variance 15
    network 192.168.2.0
    network 192.168.3.0
    network 192.168.5.0
    network 192.168.9.0
    network 192.168.101.0

    Yup, that was the first cef algorithm I had tried.   ip cef load-sharing algorithm include-ports source destination
    I tried all of the different types.
    Also, I was sending data trough iperf from 4 computers + 1 comp steaming video on one network to 5 computers on another network.  In any case of source or destination, it should have switched over.  The odds of it all going on Vlan 5 is ~ 0.6%   Restarting the router sometimes places it all on a different vlan, but in any case its all or nothing.   

  • MPLS TE equal or unequal load balancing doesn't work? - step2

    Previous question in thread:
    Dear Sir!
    I've two MPLS TE tunnels from one PE to another PE.
    And there are traffic share count between them
    (as tunnel mpls traffic-eng load-share command define).
    But in real life all traffic from the same source to the same destination go through only one tunnel
    (as CEF define - i.e. how sh ip cef exact-route says).
    PEs are 3660 platforms with c3660-jk9o3s-mz.123-8.T
    installed.
    How can I correct this problem?
    But this answer does not solved my issue:
    hritter - Network Consulting Engineer, CISCO SYSTEMS, CCIE
    Aug 4, 2004, 7:20am PST
    This is expected behavior since CEF is used at the head end to perform label imposition. I wouldn't recommend changing the default bahavior to per=packet loadsharing since this could lead to of of sequence packets, which could lower the overall performance.
    Hope this helps,
    so my secound question:
    Dear Sir!
    I'm agree with you as MPLS TE tunnels are opened from PE to PE, so CEF does it work.
    But if I open this tunnels from P to PE, ONLY ONE of this tunnels are used instead of load-sharing, if traffic go from one source (of site1 of VPN1) to the same destination (located at site2 of VPN1).
    Why? Packet through P-devices swithes by labels, so I mean that CEF cannot does src-dst load sharing?
    My problem are that I must to do load sharing between this two tunnels in the case above.
    Q: How can I solve this problem?
    Best regards,
    Maxim Denisov

    The per session load-balancing is also used by MPLS when multiple paths are available. Changing this behavior to per-packet is still not recommended.
    Hope this helps,

  • Dual ISP connection unequal load balancing

    Hi All,
    I an issue regarding load balancing between to ISP.  I have done policy based routing as stated in other cisco discussions .
     I have 2 /30 as my test ISP and isp ip configured on other switch while i have my customer configs on my end. I can ping the two test ISP from my router but not with PC's in the lan until i remove "ip nat inside source route-map 20 interface GigabitEthernet0/0.20 overload" from the routers config.
    .. Please help 
    Load-Balancing-Router#show run
    Building configuration...
    Current configuration : 2716 bytes
    ! Last configuration change at 04:09:37 UTC Tue Apr 21 2015 by anprasad
    version 15.0
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname Load-Balancing-Router
    boot-start-marker
    boot-end-marker
    no aaa new-model
    no ipv6 cef
    ip source-route
    ip cef
    ip dhcp excluded-address 192.168.1.2
    ip dhcp excluded-address 192.168.1.0 192.168.1.100
    ip dhcp pool LAN
       network 192.168.1.0 255.255.255.0
       default-router 192.168.1.1
    ip domain name fnu.ac.fj
    multilink bundle-name authenticated
    license udi pid CISCO1921/K9 sn FGL150925YE
    username anprasad privilege 15 secret 5 $1$Oy40$h13lWAN4upzI19L6/MXjf/
    username aaa privilege 15 secret 5 $1$W3JH$LMd0LUtdxJlXXJkB.NxjB0
    ip ssh version 1
    class-map match-all 512K-Outbound
     match access-group name DR-512K-OutBound
    class-map match-all 10240K-Outbound
     match access-group name DR-1024K-OutBound
    policy-map DR-Outbound
     class 10240K-Outbound
       police rate 10240000 bps burst 1920000 bytes
         conform-action transmit
         exceed-action drop
     class 512K-Outbound
       police rate 512000 bps burst 96000 bytes
         conform-action transmit
         exceed-action drop
    interface GigabitEthernet0/0
     no ip address
     duplex auto
     speed auto
    interface GigabitEthernet0/0.10
     description Student-Internet
     encapsulation dot1Q 10
     ip address 202.0.1.1 255.255.255.252
     ip nat outside
     ip virtual-reassembly
    interface GigabitEthernet0/0.20
     description Staff-Internet
     encapsulation dot1Q 20
     ip address 202.0.2.1 255.255.255.252
     ip nat outside
     ip virtual-reassembly
     shutdown
    interface GigabitEthernet0/1
     description LAN-Network
     ip address 192.168.1.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly
     duplex auto
     speed auto
    interface FastEthernet0/0/0
     no ip address
     shutdown
     duplex auto
     speed auto
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    ip nat inside source route-map 10 interface GigabitEthernet0/0.10 overload
    ip nat inside source route-map 20 interface GigabitEthernet0/0.20 overload
    ip route 0.0.0.0 0.0.0.0 202.0.1.2
    ip route 0.0.0.0 0.0.0.0 202.0.2.2
    ip access-list extended DR-10240K-OutBound
     permit ip 192.168.1.0 0.0.0.255 any
    ip access-list extended DR-512K-OutBound
     permit ip 192.168.1.0 0.0.0.255 any
    access-list 100 permit ip 192.168.1.0 0.0.0.255 any
    route-map 10 permit 10
     match ip address 100
     match interface GigabitEthernet0/0.10
    route-map 20 permit 20
     match ip address 100
     match interface GigabitEthernet0/0.20
    snmp-server community fnuro RO
    control-plane
    line con 0
     logging synchronous
     login local
    line aux 0
    line vty 0 4
     login local
    scheduler allocate 20000 1000
    end

    Hi,
    I would like to ask if you are done with your configuration? Is it working?
    next month we will add an addition ISP and I will try to configure it?
    Hope you'll give me some ideas.
    thank you

  • MPLS TE equal or unequal load balancing doesn't work?

    Dear Sir!
    I've two MPLS TE tunnels from one PE to another PE.
    And there are traffic share count between them
    (as tunnel mpls traffic-eng load-share command define).
    But in real life all traffic from the same source to the same destination go through only one tunnel
    (as CEF define - i.e. how sh ip cef exact-route says).
    PEs are 3660 platforms with c3660-jk9o3s-mz.123-8.T
    installed.
    How can I correct this problem?
    Best regards,
    Maxim Denisov

    Dear Sir!
    I'm agree with you as MPLS TE tunnels are opened from PE to PE, so CEF does it work.
    But if I open this tunnels from P to PE, ONLY ONE of this tunnels are used instead of load-sharing, if traffic go from one source (of site1 of VPN1) to the same destination (located at site2 of VPN1).
    Why? Packet through P-devices swithes by labels, so I mean that CEF cannot does src-dst load sharing?
    My problem are that I must to do load sharing between this two tunnels in the case above.
    Q: How can I solve this problem?
    Best regards,
    Maxim Denisov

  • ACE load balancing issue

    Hi,
    I have ACE module and 2 servers the problem i am facing is only one server is been serviced by ACE the other server is not getting much traffic at all.
    One server gets hit most of the time like 3 pkts goes to server 1 and 1 pkt goes to server 2.
    Could anyone tell me why is this issue that unequal load balancing is occoring on my device.
    Thanks in advance.

    here's the output of
    sh serverfarm det
    serverfarm : DNS, type: HOST
    total rservers : 2
    active rservers: 2
    description : -
    state : ACTIVE
    predictor : ROUNDROBIN
    failaction : -
    back-inservice : 0
    partial-threshold : 0
    num times failover : 0
    num times back inservice : 0
    total conn-dropcount : 0
    Probe(s) :
    DNS_PROBE, type = DNS
    ----------connections-----------
    real weight state current total failures
    ---+---------------------+------+------------+----------+----------+---------
    rserver: DNS-118-1
    10.0.0.1:0 8 OPERATIONAL 206 127901 1
    max-conns : - , out-of-rotation count : -
    min-conns : -
    conn-rate-limit : - , out-of-rotation count : -
    bandwidth-rate-limit : - , out-of-rotation count : -
    retcode out-of-rotation count : -
    load value : 0
    rserver: DNS-118-2
    10.0.0.2:0 8 OPERATIONAL 230 212332 4
    max-conns : - , out-of-rotation count : -
    min-conns : -
    conn-rate-limit : - , out-of-rotation count : -
    bandwidth-rate-limit : - , out-of-rotation count : -
    retcode out-of-rotation count : -
    load value : 0
    here's the output of
    sh service-policy L3L4_LOADB detail
    Status : ACTIVE
    Description: -----------------------------------------
    Context Global Policy:
    service-policy: L3L4_LOADB
    class: CLASS_MAP
    nat:
    nat dynamic 1 vlan 118
    curr conns : 325 , hit count : 340457
    dropped conns : 5
    client pkt count : 2697687 , client byte count: 179735431
    server pkt count : 2694477 , server byte count: 535957631
    conn-rate-limit : 0 , drop-count : 0
    bandwidth-rate-limit : 0 , drop-count : 0
    VIP Address: Protocol: Port:
    10.0.0.3 tcp eq 53
    10.0.0.3 udp eq 53
    loadbalance:
    L7 loadbalance policy: L7_LOADB
    VIP Route Metric : 77
    VIP Route Advertise : ENABLED-WHEN-ACTIVE
    VIP ICMP Reply : ENABLED-WHEN-ACTIVE
    VIP State: INSERVICE
    curr conns : 325 , hit count : 340462
    dropped conns : 5
    client pkt count : 2697687 , client byte count: 179735431
    server pkt count : 2694477 , server byte count: 535957631
    conn-rate-limit : 0 , drop-count : 0
    bandwidth-rate-limit : 0 , drop-count : 0
    L7 Loadbalance policy : L7_LOADB
    class/match : class-default
    LB action: :
    primary serverfarm: DNS
    state: UP
    backup serverfarm : -
    hit count : 340457
    dropped conns : 0

  • EIGRP load balancing when using HSRP on LAN

    Hi 
    I have a question about my topology. I have two routers  with EIGRP on both of them connected through 2 ISPs to other site. On those routers i have HSRP runing. Now my question is: HSRP is standby/active protocol so when one router act as active will it send data to other site only through one ISP??? will load balancing work on WAN side? will routers use both ISPs or just one- the one which is active in HSRP when sending data???

    Hi sotiris_pafitis, may be I didn't understand what you mean but if the idea is to configure one static on each router  (pointing it's ISP) and redistribute it in EGRIP, I disagree: is useless because the other router will prefer the static route due to its better administrative distance. Using EIGRP unequal load balancing is useless because  it balanced EIGRP path with different metric, not different Administrative distance. Isn't it ?
    If you want to use static route simply configure two static route on each router: one though WAN interface and the other through the LAN.
    For example:
    R1#conf t
    ip route 0.0.0.0 0.0.0.0 192.168.13.3
    ip route 0.0.0.0 0.0.0.0 192.168.12.2
    The result is:
    R1#sh ip route 0.0.0.0
    Routing entry for 0.0.0.0/0, supernet
      Known via "static", distance 1, metric 0, candidate default path
      Redistributing via eigrp 100
      Advertised by eigrp 100
      Routing Descriptor Blocks:
      * 192.168.13.3
          Route metric is 0, traffic share count is 1
        192.168.12.2
          Route metric is 0, traffic share count is 1
    In any case I think static router is not a good choice: in case of a fault on ISP 1, WAN interface can remain up producing a routing blackhole. If possible it's better to have a dynamic routing protocol between router and ISP, receving the default route and changing delay on interf to have the same metric for both  the path 
    Bye,
    enrico

  • RSPAN Load Balance

    Hi everybody! I go straight to the problem I'm facing:
    I need to send a data stream via RSPAN to a remote device for traffic analysis. Because of the large amount of data (>1Gbps) I need to put the remote VLAN, which carries the RSPAN traffic, on an etherchannel and to load-balance that traffic among the members of the etherchannel.
    The problem is that it seems that there's no algorithm I can use to load-balance the RSPAN traffic. The device I'm using  is a Cisco 3750 switch, so no per-packet load balancing algorithm is available (and I think that, even if I could use this technique, I would encounter some sort of out-of-sequence packets issue).
    Is there a way to efficiently load balance a RSPAN traffic on an etherchannel?

    Hey Enrico,
    Etherchannel will perform load balancing as per the selected hashing algorithm. In 3750 default is src-mac address so it will only check the source mac-address of RSPAN traffic while performing load balancing across etherchannel. So you may change it to a more granular value, available options are provided in link below:http://www.cisco.com/en/US/docs/switches/lan/catalyst3750x_3560x/software/release/12.2_53_se/configuration/guide/swethchl.html#wp1276203
    HTH.
    Regards,
    RS.

  • LOAD BALANCE BEHAVIOR FOR 7600 ON ETHERCHANNELS

    Hi Everyone,
    Currently I'm planning to implement ether-channels on 7600 routers, but there's something that's still not clear to me, regarding the load balancing behavior, for L2VPN and L3VPN.
    I've read that 7600 in MPLS default load balance behavior is to take  the SIP and DIP if present and the bottom of the stack label or the 5th label depending upon the number of labels on the stack. In l2VPN scenarios when ether-channel is used, if no IP traffic is present what is the default behavior of the etherchannel to calculate the load balancing hash function to select a given link on the bundle.
    I'll appreciate any feedback regarding this.

    Hi Louis, you could set default routes on the ASA's with tracking, and use ospf downstream to inject the default route in to the network with default information originate - this will only advertise out a default route if it has it in the routing table. With SLA you can track internet reachability by IP SLA echo to something like 8.8.8.8. Both sides can advertise this in to the network, if one goes then there is one left. Just be mindful of the policies and NAT required, you will have to duplicate the rules on the ASA's. With the NAT you have to ensure, that outgoing traffic comes back in the same path it left so it doesn't break connections.

  • Etherchannel Load-Balancing To Host (Confused)

    I'm a bit confused as to how an etherchannel load-balances traffic across all the links, in the port-channel.  If I have a 4 port etherchannel, to an AIX host, does the traffic load balance across all 4 ports?   In reading the load-balancing documentation, it states that a global configuration of src-mac forwards traffic from the same host, over the same port, all the time, whereas it forwards traffic over different ports for other hosts.  What if it's the same host tied into the port-channel?  So if my AIX box has 4 ethernet cards in a port channel, each ethernet card goes over only one link?  If the ethernet cards are bundled, into a port channel config, is there no way to load balance all the traffic?  Maybe I'm misunderstanding the etherchannel configuration and how it works.  Thanks for any and all help!!
    Dan

      Port channel is link aggregation for all traffic which will get distributed across all links.  A given ip conversation will only travel down one of those links at any given time. The single ip conversation is not carried say for instance across all 4 links if it's a 4 port etherchannel.

  • Etherchannel load balancing options

    Reading up on my Etherchannel load balancing options (src or dst, mac or IP) it seems to me that I don't have a good way of using Etherchannel to increase bandwidth in my situation. In my scenario, I have a Windows terminal server servicing a couple hundred users which are using a SQL database on a 2nd server. Both servers are on the same switch. Basically I only have one MAC and one IP. Is there a way to utilize multiple links in this scenario? It seems like I would need a packet based technique to take advantage of multiple channels and unfortunately that isn't an option with etherchannel. Thoughts?
    Thanks,
    Diego

    Hi Diego,
    If I understand you correctly, your scenario is similar to this
    200users--Switch===channel===Switch--Server1+2
    If that's how it is set up, then you have multiple source addresses with the same destination address. So if you select either 'source' or 'source and destination' as your frame distribution method, then you should have a pretty even distribution of traffic.
    HTH,
    Bobby
    *Please rate helpful posts.

  • How does CEF perform equal and unequal cost load balancing?

    hello
    How does CEF perform equal and unequal cost load balancing?
    thanks

    Hello Wang,
    it is only EIGRP that can perform load balancing over unequal cost links.
    For equal cost links CEF allocates 16 buckets and maps them to the the physical links.
    the result of a binary operation is used to associated a packet to an outgoing interface:
    Source IP address EXOR DEstination IP Address EXOR hash
    the hash is a seed that changes only at every reload.
    Actually the last 4 bits are used so that each flow can be classified in one bucket.
    then the outgoing interface is the one asscociated to the result of the exor operation.
    Another way to see is that m bits are used so that 2^m is equal to N number of links (if N is even)
    the rule is simple and pre-established
    Hope to help
    Giuseppe

  • Etherchannel Load balancing

    I have three Gigabit aggregated with LACP to a IBM server. When I ask one ftp from this server I saw the performance is around 80 MB/s, if I ask two ftp to different equipmpents the performance is 160 MB/s (it uses 2 of the links of the bundle). However if I ask for three ftp the performance keeps in 160 MB/s although it uses the three links of the bundle. Is there a limit for Cisco? Anyone knows the reason? It seems like we can transmit as maximum at 160 MB/s

    Glen is absolutely correct. on layer 2 switches EtherChannel load balancing can use either source-MAC or destination-MAC address forwarding.
    With source-MAC address forwarding, when packets are forwarded to an EtherChannel, the packets are distributed across the ports in the channel based on the source-MAC address of the incoming packet. Therefore, to provide load balancing, packets from different hosts use different ports in the channel, but packets from the same host use the same port in the channel. With destination-MAC address forwarding, when packets are forwarded to an EtherChannel, the packets are distributed across the ports in the channel based on the destination host MAC address of the incoming packet. Therefore, packets to the same destination are forwarded over the same port, and packets to a different destination are sent on a different port in the channel.
    So with every different source or destination mac it will use a diff link. If there is a session started on a aprticular link for a source to a destination it will keep on using the same link until the session termiantes or link goes down.
    HTH, Please rate if it helps.
    -amit singh

  • Etherchannel Load-Balance

    Hi All,
    I have one Catalyst 6509 connected to Catalyst 4500X-VSS using a Layer 2 Etherchannel.
    So, 6509 are using src-dst-ip for Etherchannel Load Balance and 4500X are using src-dst-port.
    Anyone knows if this will work fine or if I may have some problem?
    Is recommended change that configuration or not?
    Tks.

    I agree with Karsten, That there would be any problem.
    As you know Etherchannel is kind of load sharing among the links...It has its own way of load sharing/balancing the traffic if you leave it to default. (which means you might end up using the same link most often times if you dont change the default load balancing method). Hence we see people change the default method to the one which they want and get the nearest load sharing/balancing over the links utilization.
    HTH
    REgards
    Inayath

  • Help choose the appropriate etherchannel load balance method

    Hi
    I have 2 network architectures :case A and case B  (found architecture below)
    Case A : one server connected on the switch on each site
    Case B : 3 server connected on the switch behind a router on each site
    2 site are connected by 2 wireless link :each wireless link have 105 Mbps bandwith (I absolutly need the agregate bandwith 210)
    Site headquarter is the principal site and site backup is use to backup data located on the principal site
    I use Gbit cisco  2960 switch
    I use etherchannel to agregate the 2 switch port (port 1 and port 2) where the 2 wireless link are connected
    I configure src-mac for case A but all trafic is send only on one wireless link .
    Please help me to choose the more appropriate load balance method to load balance traffic between the 2 link for the case A and for the case B
    Please advise
    Thanks in advance

    Disclaimer
    The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
    Liability Disclaimer
    In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
    Posting
    Your Case A might be handled by port hashing, but unfortunately most Cisco platforms don't support it.
    Your Case B isn't much better, as you only have 3 hosts on each side, and according to your drawing, they are behind routers, so you don't want to use MAC hashes.  If you don't have port hashing, next best choice might be src-dest-IP hashing.  Again, though, with just 3 hosts, your distribution will likely not be very balanced, especially over shorter time intervals.
    To obtain best utilization of your links, you need some kind of better link bonding, such as MLPPP (unfortunately, usually won't scale to FE rates) or a hardware MUX.  Next best option, if you could route across the links, would be something like Cisco's OER/PfR which can dynamically load balance.

Maybe you are looking for

  • How to use one Assign action to create multiple context variables

    Hello, everyone. I read some tips from Oracle documentation that said: Avoid creating many OSB context variables that are used just once within another XQuery Context variables created using an Assign action are converted to XmlBeans and then reverte

  • Aperture in full screen mode seems to crash MacBook Pro with Retina

    To anyone who has an idea; I have a brand new (couple months old) 15" MacBook Pro w Retina (16GB RAM, 2.3GHz i7) and I can repeatedly crash it just by running Aperture in a full screen mode and flipping through the photos (I have 21000+ photos and I

  • [SOLVED] urxvt/console spanish characters

    i didn't bother with this "issue" i have, because rarely i type something in spanish (my native language) in urxvt, but lately i had to use msn a lot, (yeah i hate it too, but here people use that... and facebook) so, i have to use a lot the "n" and

  • 2G died should I go for the Gs

    My original iphone just died..with my help (a drop) and I have the goPhone pick your plan option. As I understand it I am not eligible for an upgrade with the nice prices...so I have to purchase at full price and get a 2 year contract/.... I sooooooo

  • Failure in redirecting Personal Domain Emails to B...

    I've tried emailing BT but had no response, so posting here. I've discovered that over the last month or so an unknown quantity of emails to my personal domain have bounced.  These have included emails from BT.  My domain is managed by 123-reg and em