VLC player RTSP server - JMF client

Hello,
I want to write application which can capture RTSP stream from VLC player. I am just beginner and don`t know where is problem. Can anybody help me, please? Here is my code, console output and log file.
import javax.media.ControllerEvent;
import javax.media.ControllerListener;
import javax.media.Manager;
import javax.media.MediaLocator;
import javax.media.NoPlayerException;
import javax.media.RealizeCompleteEvent;
import javax.media.StartEvent;
import javax.swing.SwingUtilities;
import java.awt.BorderLayout;
import java.awt.Component;
import java.awt.Dimension;
import javax.swing.JPanel;
import javax.swing.JFrame;
import java.awt.Rectangle;
import java.io.IOException;
import javax.media.Player;
public class prehravacRTP extends JFrame implements ControllerListener {
     private static final long serialVersionUID = 1L;
     private JPanel jContentPane = null;
     private JPanel jPanel_Video = null;
     Player player = null;
     String url = null;
     MediaLocator mrl = null;
     Component visualComp = null;
     private JPanel getJPanel_Video() {
          if (jPanel_Video == null) {
               jPanel_Video = new JPanel();
               jPanel_Video.setLayout(new BorderLayout());
               jPanel_Video.setBounds(new Rectangle(4, 3, 448, 333));
          return jPanel_Video;
     void setLocation(){
          url= "rtsp://192.168.1.100:5544/video.mov";
          mrl= new MediaLocator(url);
          if (mrl == null) {
               System.err.println("Can't build MRL");
               System.exit(1);
     void realizeRTSP(){
          try {
               player = Manager.createPlayer(mrl);
          } catch (NoPlayerException e) {
               // TODO Auto-generated catch block
               e.printStackTrace();
          } catch (IOException e) {
               // TODO Auto-generated catch block
               e.printStackTrace();
          player.addControllerListener(this);
          player.realize();
     public synchronized void controllerUpdate(ControllerEvent evt){
          System.out.println(evt.toString());
          if(evt instanceof StartEvent){
               Player p = (Player) evt.getSourceController();
               visualComp = p.getVisualComponent();
              if (visualComp != null){
                   Dimension d = visualComp.getPreferredSize();
                   jPanel_Video.setSize(d);
                   jPanel_Video.add("North", p.getVisualComponent());
                   jPanel_Video.setVisible(true);
                   validate();
          if(evt instanceof RealizeCompleteEvent){
               player.start();
     public static void main(String[] args) {
          SwingUtilities.invokeLater(new Runnable() {
               public void run() {
                    prehravacRTP thisClass = new prehravacRTP();
                    thisClass.setDefaultCloseOperation(JFrame.EXIT_ON_CLOSE);
                    thisClass.setVisible(true);
     public prehravacRTP() {
          super();
          initialize();
     private void initialize() {
          this.setSize(465, 369);
          this.setContentPane(getJContentPane());
          this.setTitle("RTSP Player");
          setLocation();
          realizeRTSP();
     private JPanel getJContentPane() {
          if (jContentPane == null) {
               jContentPane = new JPanel();
               jContentPane.setLayout(null);
               jContentPane.add(getJPanel_Video(), null);
          return jContentPane;
Open log file: C:\Program Files\JMF2.1.1e\bin\\jmf.log
javax.media.TransitionEvent[source=com.sun.media.content.rtsp.Handler@1c0ec97,previous=Unrealized,current=Realizing,target=Realized]
bandwidth info: RR:0
javax.media.ResourceUnavailableEvent[source=com.sun.media.content.rtsp.Handler@1c0ec97,message=Failed to realize: Message from RTSP Server - Not found]
javax.media.ControllerClosedEvent[source=com.sun.media.content.rtsp.Handler@1c0ec97]
# JMF Version 2.1.1e
## Platform: Windows XP, x86, 5.1
## Java VM: Sun Microsystems Inc., 1.5.0_12
## Player created: com.sun.media.content.rtsp.Handler@1c0ec97
##   using DataSource: com.sun.media.protocol.rtsp.DataSource@1bb60c3
## outgoing msg:
## DESCRIBE rtsp://192.168.1.100/video.mov RTSP/1.0
CSeq: 928
Accept: application/sdp
User-Agent: JMF RTSP Player Version 2.1.1e
## incoming msg:
## RTSP/1.0 200 OK
Server: VLC/1.1.4
Date: Tue, 23 Nov 2010 15:35:49 GMT
Content-Type: application/sdp
Content-Base: rtsp://192.168.1.100:5544/video.mov
Content-Length: 344
Cache-Control: no-cache
Cseq: 928
v=0
o=- 15030303979736870809 15030303979736870809 IN IP4 fonzzy-laptop
s=Unnamed
i=N/A
c=IN IP4 0.0.0.0
t=0 0
a=tool:vlc 1.1.4
a=recvonly
a=type:broadcast
a=charset:UTF-8
a=control:rtsp://192.168.1.100:5544/video.mov
m=video 0 RTP/AVP 96
b=RR:0
a=rtpmap:96 H263-1998/90000
a=control:rtsp://192.168.1.100:5544/video.mov/trackID=8
## Add RTP dynamic payload for video: 96 : h263-1998/rtp
## outgoing msg:
## SETUP rtsp://192.168.1.100:5544/video.movrtsp://192.168.1.100:5544/video.mov/trackID=8 RTSP/1.0
CSeq: 929
Transport: RTP/AVP;unicast;client_port=38658-38659
User-Agent: JMF RTSP Player Version 2.1.1e
## incoming msg:
## RTSP/1.0 404 Not found
Content-Length: 366
Content-Type: text/html
<?xml version="1.0" encoding="ascii" ?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml10/DTD/xhtml10strict.dtd">
<html lang="en">
<head>
<title>Not found</title>
</head>
<body>
<h1>404 Not found (/video.movrtsp://192.168.1.100:5544/video.mov/trackID=8)</h1>
<hr />
<a href="http://www.videolan.org">VideoLAN</a>
</body>
</html>
!! [SDP Parser] Token missing: v=Every help will by appreciated. Thank you.

Thank you for responce captfoss,
I have also option to stream HTTP with VLC. I tried stream mp3 and it`s working. My application start caching than start player and keep caching. With video I have problem. Application starts caching than start player, but only shows one frame and than again prefetched state.
javax.media.TransitionEvent[source=com.sun.media.content.video.mpeg.Handler@170888e,previous=Unrealized,current=Realizing,target=Realized]
javax.media.CachingControlEvent[source=com.sun.media.content.video.mpeg.Handler@170888e,cachingControl=com.sun.media.protocol.DataSource$CachingControl@b9e45a,progress=103737]
javax.media.CachingControlEvent[source=com.sun.media.content.video.mpeg.Handler@170888e,cachingControl=com.sun.media.protocol.DataSource$CachingControl@b9e45a,progress=204912]
javax.media.CachingControlEvent[source=com.sun.media.content.video.mpeg.Handler@170888e,cachingControl=com.sun.media.protocol.DataSource$CachingControl@b9e45a,progress=307848]
javax.media.CachingControlEvent[source=com.sun.media.content.video.mpeg.Handler@170888e,cachingControl=com.sun.media.protocol.DataSource$CachingControl@b9e45a,progress=409609]
javax.media.CachingControlEvent[source=com.sun.media.content.video.mpeg.Handler@170888e,cachingControl=com.sun.media.protocol.DataSource$CachingControl@b9e45a,progress=513394]
javax.media.CachingControlEvent[source=com.sun.media.content.video.mpeg.Handler@170888e,cachingControl=com.sun.media.protocol.DataSource$CachingControl@b9e45a,progress=614423]
javax.media.CachingControlEvent[source=com.sun.media.content.video.mpeg.Handler@170888e,cachingControl=com.sun.media.protocol.DataSource$CachingControl@b9e45a,progress=717655]
javax.media.CachingControlEvent[source=com.sun.media.content.video.mpeg.Handler@170888e,cachingControl=com.sun.media.protocol.DataSource$CachingControl@b9e45a,progress=819369]
javax.media.CachingControlEvent[source=com.sun.media.content.video.mpeg.Handler@170888e,cachingControl=com.sun.media.protocol.DataSource$CachingControl@b9e45a,progress=923076]
javax.media.CachingControlEvent[source=com.sun.media.content.video.mpeg.Handler@170888e,cachingControl=com.sun.media.protocol.DataSource$CachingControl@b9e45a,progress=1024742]
javax.media.RealizeCompleteEvent[source=com.sun.media.content.video.mpeg.Handler@170888e,previous=Realizing,current=Realized,target=Realized]
javax.media.TransitionEvent[source=com.sun.media.content.video.mpeg.Handler@170888e,previous=Realized,current=Prefetching,target=Prefetched]
javax.media.PrefetchCompleteEvent[source=com.sun.media.content.video.mpeg.Handler@170888e,previous=Prefetching,current=Prefetched,target=Prefetched]
javax.media.StartEvent[source=com.sun.media.content.video.mpeg.Handler@170888e,previous=Prefetched,current=Started,target=Started,mediaTime=javax.media.Time@14e8cee,timeBaseTime=javax.media.Time@67064]
javax.media.EndOfMediaEvent[source=com.sun.media.content.video.mpeg.Handler@170888e,previous=Started,current=Prefetched,target=Prefetched,mediaTime=javax.media.Time@3c9217]
javax.media.DurationUpdateEvent[source=com.sun.media.content.video.mpeg.Handler@170888e,duration=javax.media.Time@9b42e6
javax.media.CachingControlEvent[source=com.sun.media.content.video.mpeg.Handler@170888e,cachingControl=com.sun.media.protocol.DataSource$CachingControl@b9e45a,progress=1126585]
javax.media.CachingControlEvent[source=com.sun.media.content.video.mpeg.Handler@170888e,cachingControl=com.sun.media.protocol.DataSource$CachingControl@b9e45a,progress=1229673]I also tried add this to event controller without success.
if(evt instanceof PrefetchCompleteEvent){
               player.start();
}Any suggestion? Thank you.
Edited by: 814939 on Nov 24, 2010 5:02 AM

Similar Messages

  • RMI or RTSP for Video Client/Server??????

    I am about to write a media streaming server and client in Java using JMF. I would like to use RMI to control the media streams, however, RTSP looks like a good alternative. Can anyone here provide me with any pro's and con's to using either approach.
    Thanks.

    hi, i am currently working on a project that streams video via JMF. the protocol i used is RTSP... it seems quite ok with RTSP to stream local static files through the LAN (Wireless LAN).
    by the way . i am asked to send 2 streams with different resolutions (screen sizes) for laptops and PDAs respectively.... do you have any idea to create the two streams >?

  • Windows Media Player no sound while playing a avi file in server and client connection using TCP/IP connection

    Hello there
    I have a problem with my windows media player while using server and client connection by using TCP/IP connection. So when I play a video using Windows Media Player in LabVIew there isn't any sound come out but when I'm playing a video by a Windows Media Player only the sound will come out. Can you help me solve this problem?
    I also upload the vi as the reference.
    The username for the client is ihsanhaikalz and the password is ganteng
    Thanks
    Attachments:
    Client Remote.vi ‏746 KB
    Server Remote.vi ‏1433 KB

    Hi ican,
    I was looking at your VI's but I cannot seem to pinpoint exactly where you are using Windows Media Player.  In order to more quickly assist you, could you please recreate this issue more concisely in a smaller set of VIs.  Also, were you able to get sound when you did not use the TCP/IP connection and simply played the files in LabVIEW?
    I noticed in a few places that you were using the Play Sound File.VI from the Graphics and Sounds palette.  Is that what you are refering to?  I noticed there that the file path that you have designated for the song is simply the song title.  Instead, this should be a path to where the song is located on your computer.
    Also, if you are planning on using Windows Media Player, have you considered using the ActiveX commands for Windows Media Player?  Here are a few examples if you are unfamiliar with this functionality.
    Example 1 and Example 2.
    I hope this helps!
    Kim W.
    Applications Engineer
    National Instruments

  • RTSP server to QuickTime Client

    Hi,
    I would like to build my own Java RTSP server that runs with QuickTime Client. Does anyone know any Java RTSP libary that I can use? I couldn't find any that is implemented in Java.
    Does anyone know where I can find the spec that QuickTime used to implement its RTSP client? I tried to implement my Java RTSP server based off the RTST rfc 2326 but it seems like the QuickTime client isn't accepting the SETUP reply my server sent. The client doesn't give back the PLAY request.
    Appreciate your help!

    Hi kongdy. If you don't get any replies to your question here, it might be worth checking in at the QuickTime-users mailing list. Here's a link:
    http://lists.apple.com/mailman/listinfo/quicktime-users

  • Airplay/Mirroring for video on VLC Player

    I am expecting my mid-2013 27" iMac in the mail shortly but my question is can I watch VLC player via airplay/display mirroring on my TV?  I will be running the latest version of Yosemite. Is this possible with the Apple TV (sound included), or is there an alternative to the apple TV for this purpose?    I currently am using a thunderbolt-HDMI cable from my mid-2010 MacBook for this but would like to do this wirelessly.

    elmerfromelkridge wrote:
    So what i don't understand about the "not a file" comment is that macs have vnc installed native which allows basic "wireless" screen display on another mac.  Why not let the desktop be mirrore over to tv?
    VNC (build in Mac solution) need a VNC Server (source) and a VNC Client (destination) to work.
    If you connect (screen sharing) two Mac's or a Mac and a PC you will have as well a sever and a client running.
    As soon as your TV enables you to install a VNC Client and let you start it, you have what you want.
    Apple TV receive a constant multicast stream from the source (e.g. your Mac) to display e.g. a video. Also ATV buffers a part of the stream to unpack the compressed data, decode video / audio and deliver screen and sound synchronous.
    That is a total different technic compared to a screen sharing.
    Lupunus

  • I am Stuck! Need Help With Multicast Streaming Using VLC Player

    I have a Multicast network topology shown below
    and my configs
    HUB ROUTER
    no ip domain lookup
    ip domain name primestarhotel.com
    ip multicast-routing
    interface Loopback0
    ip address 5.5.5.5 255.255.255.255
    ip pim sparse-dense-mode
    interface FastEthernet0/0
    ip address 200.0.0.2 255.255.255.240
    ip pim sparse-dense-mode
    ip virtual-reassembly
    speed 100
    full-duplex
    interface FastEthernet0/1.65
    description "Server Vlan"
    encapsulation dot1Q 65
    ip address 10.1.65.1 255.255.255.0
    ip pim sparse-dense-mode
    ip virtual-reassembly
    router ospf 200
    log-adjacency-changes
    network 5.5.5.5 0.0.0.0 area 0
    network 10.1.65.0 0.0.0.255 area 0
    network 200.0.0.0 0.0.0.15 area 0
    ip route 200.1.1.0 255.255.255.252 200.0.0.1
    ip route 200.2.2.0 255.255.255.252 200.0.0.1
    no ip http server
    no ip http secure-server
    ip pim send-rp-announce Loopback0 scope 6
    ip pim send-rp-discovery Loopback0 scope 6
    ISP ROUTER
    interface FastEthernet1/0
    interface FastEthernet1/1
    no switchport
    ip address 200.0.0.1 255.255.255.240
    ip pim sparse-dense-mode
    duplex full
    speed 100
    interface FastEthernet1/2
    no switchport
    ip address 200.1.1.1 255.255.255.252
    ip pim sparse-dense-mode
    duplex full
    speed 100
    interface FastEthernet1/3
    no switchport
    ip address 200.2.2.1 255.255.255.252
    ip pim sparse-dense-mode
    duplex full
    speed 100
    router ospf 200
    log-adjacency-changes
    network 200.0.0.0 0.0.0.15 area 0
    network 200.1.1.0 0.0.0.3 area 0
    network 200.2.2.0 0.0.0.3 area 0
    SPOKE 1 Router
    interface FastEthernet0/0
    ip address 200.1.1.2 255.255.255.252
    ip pim sparse-dense-mode
    speed 100
    full-duplex
    interface FastEthernet0/1
    no ip address
    ip pim sparse-dense-mode
    ip virtual-reassembly
    speed 100
    full-duplex
    interface FastEthernet0/1.12
    description "Workstation pc"
    encapsulation dot1Q 12
    ip address 10.1.12.1 255.255.255.0
    ip pim sparse-dense-mode
    router ospf 200
    log-adjacency-changes
    network 10.1.12.0 0.0.0.255 area 0
    network 200.1.1.0 0.0.0.3 area 0
    ip route 0.0.0.0 0.0.0.0 200.1.1.1
    SPOKE 2
    interface FastEthernet0/0
    ip address 200.2.2.2 255.255.255.252
    ip pim sparse-dense-mode
    speed 100
    full-duplex
    interface FastEthernet0/1
    ip address 10.2.22.1 255.255.255.0
    ip pim sparse-dense-mode
    speed 100
    full-duplex
    router ospf 200
    log-adjacency-changes
    network 10.2.22.0 0.0.0.255 area 0
    network 200.2.2.0 0.0.0.3 area 0
    ip route 0.0.0.0 0.0.0.0 200.2.2.1
    ip route 200.2.2.0 255.255.255.252 200.0.0.1
    I have implemented multicast on the network in a hub and spoke topology. i have set up ospf routing protocol and broadcast all network and can successfully ping.
    I am currently using VLC player as my media streaming server and client. i have set up rtp streaming from the HUb router using multicast ip 224.2.2.2 and unable to broadcast the multicast traffic across the spokes 1 and 2 PC's
    I have never used vlc player  never set up multicast network before and i am struggling with this and need help.
    these are my router configs below
    http://dl.dropbox.com/u/20145606/ip%20video%20config.txt
    Message was edited by: Louis Ojuwu

    I have edited the message and the configs and topology are visible above now. instead of the links i provided

  • Quicktime 7 Problem on RTSP Server

    We're having problems with movies streamed from our rtsp server, starting with the release of Quicktime 7.
    Suddenly, Quicktime movies display no video, only the audio track, (transport bar shows up in the middle of the screen). This problem shows up on PC's only, the videos play fine on Macs.
    By changing the link in my html file to load the same movie stored on an http server instead of an rtsp server, the file plays fine.
    Downgrading to Quicktime 6.5.2 fixes the problem, but we can't ask all our users to downgrade their Quicktime aps.
    Any suggestions? Please help.
    Thanks,
    Mike
    Dual Core Intel   Mac OS X (10.4.10)  

    The file "loaded" via the RTSP URL on my Mac using Safari Beta 3 so that rules out javascript issues that I suspected being the cause. Page code is rather clumsy and needs some work:
    http://developer.apple.com/internet/ieembedprep.html
    The file itself had some other issues for me and my DSL connection:
    rtsp://qt.scoe.net/efa/EPISODE1/EP1Pt1.mov
    Copy the URL above and open the URL using QuickTime Pro (I hope you have Pro).
    Open the Movie Properties window, highlight the streaming track and click the "Statistics" tab. Mine shows a packet loss of over 70% and the video is not viewable. I tried it in both version 6 and 7 of QuickTime with the same results. Real Player (it can open .mov files too) also gave poor playback and VLC just plain failed.
    I don't know anything about RTSP servers but the issue seems to point in that direction.

  • Playing the DVD on VLC player

    Hi there
    I have authored a dvd in dvd studio pro and it has to play on PCs. Since it is very copy heavy it looks really crappy when played in WMP. Someone suggested i include vlc player on the dvd to play off and indeed the quality is great. it however jumps from one scene to the other and does not play in sequence, while in all the other players it plays in the correct sequence but worse quality
    anyone have any ideas?
    thank you for all the help
    jammy

    my advice to all my clients is to never use windows media player for playing DVD video
    the results are very poor if the video plays at all.
    the user must install a separate decoder for MPEG 2 video that is compatable with windows media player. Most users will not have the patience, ability or resources to do this
    Many users will be viewing the DVD on networked computers which will not allow users to install or change local configurations
    If the user has a DVD drive, it will be much simpler to use the supplied DVD software player that will be installed on the computer already
    G

  • Turn Windows Phone into a video streaming server (not client)?

    I want to stream video from a Windows Phone 8/8.1 device but I'm not sure where to start.  I have done extensive web searching for C# examples or libraries to do this but everything I have found so far covers using the phone as a
    client, not as a source.
    I'm guessing I need to turn the phone into an RTSP server? If not, what is the correct technique or starting point for doing this?  Main concerns are that the streaming be smooth and with minimal lag, since the Windows Phone (camera) is mounted on a robot
    for remote navigation.  Too much lag or video performance problems and navigation will be impossible.  Any libraries or samples that show how to do this are greatly appreciated.
    -- roschler

    Hi Roschler,
    Per my understanding, it is not support in public API. If you need this feature, you can vote it on UserVoice.
    https://wpdev.uservoice.com/forums/110705-dev-platform.
    If you are OEM developer, you can use your own channel to check if there is such API.
    Regards,
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click
    HERE to participate the survey.

  • After clearing cash on mac applications won't lunch any more..I tried to delete apps like VLC player with app cleaner and again download and instal new but it's the same..goes for all apps that are not originally part of Yosemite. Please advise me?!

    After clearing cash on my mac ( Go to folder: ~/Library/Caches and clear all, than to Library/Cashes and clear all again) applications won't lunch any more..I tried to delete apps like VLC player, firefox.. with app cleaner and again download and install the new one but it's the same..goes for all apps that are not originally part of Yosemite. I have done this cash clean up very often on Maverick without any problems. This time I done it again because I could not open my web site, the server has blocked me and I was trying everything including deleting cash from mac. Please advise me what to do..?!? Thanks in advance.

    It sounds like you may have multiple problems, but none of them are likely to be caused by malware.
    First, the internet-related issues may be related to adware or a network compromise. I tend to lean more towards the latter, based on your description of the problem. See:
    http://www.adwaremedic.com/kb/baddns.php
    http://www.adwaremedic.com/kb/hackedrouter.php
    If investigation shows that this is not a network-specific issue, then it's probably adware. See my Adware Removal Guide for help finding and removing it. Note that you mention AdBlock as if it should have prevented this, but it's important to understand that ad blockers do not protect you against adware in any way. Neither would any kind of anti-virus software, which often doesn't detect adware.
    As for the other issues, it sounds like you've got some serious corruption. I would be inclined to say it sounds like a failing drive, except it sounds like you just got it replaced. How did you get all your files back after the new drive was installed?
    (Fair disclosure: I may receive compensation from links to my sites, TheSafeMac.com and AdwareMedic.com, in the form of buttons allowing for donations. Donations are not required to use my site or software.)

  • Problems with games server and client

    Hi! I am making an MMORPG game and I have problems with the server and client connection.
    I can connect to the server, but when a second player does, the server console tells me this:
    java.net.SocketException: Connection reset
    After that, all clients disconnect.
    Which is the problem?
    How can I solve it?
    Thank you so much

    Here is how my sever work. I took some of this code from a book called Killer Programming Games in Java. If you google for it, you will find it for sure.
    TourGroup tg = new TourGroup(); // this object stores information about all clients connected to the server
        try {
          ServerSocket serverSock = new ServerSocket(PORT);
          Socket clientSock;
          while (true) {
            System.out.println("Waiting for a client...");
            clientSock = serverSock.accept();
            new TourServerHandler(clientSock, tg).start(); // this is the thread that monitors each client
        catch(Exception e)
        {  System.out.println(e);  }
      } This is some code of TourServerHandler
    public TourServerHandler(Socket s, TourGroup tg)
        this.tg = tg;
        clientSock = s;
        name= "?";
        cliAddr = clientSock.getInetAddress().getHostAddress();
        port = clientSock.getPort();
        System.out.println("Client connection from (" +
                     cliAddr + ", " + port + ")");
    public void run()
      // process messages from the client
        try {
          // Get I/O streams from the socket
          BufferedReader in  = new BufferedReader(
       new InputStreamReader( clientSock.getInputStream() ) );
          PrintWriter out =
    new PrintWriter( clientSock.getOutputStream(), true );  
    // and here goes the rest... The TourServerHandler thread uses this code to send messages:
    tg.broadcast(msg); tg.broadcast works like this:
    synchronized public void broadcast(String cliAddr, int port, String msg)
      // broadcast to everyone but original msg sender
        TouristInfo c; // this object stores info about the client
        for(int i=0; i < tourPeople.size(); i++) {
          c = (TouristInfo) tourPeople.get(i);
            c.sendMessage(msg);
      } This is the error part
    public void sendMessage(String msg)
      PrintWriter out;  
        out.println(msg);  
          System.out.println("OK");
      } I can't find any error but I still get that Connection reset exception...

  • [Microsoft][SQL Server Native Client 11.0][SQL Server]The text, ntext, and image data types cannot be compared or sorted, except when using IS NULL or LIKE operator.  'Items' (OITM) (OITM)

    Dear Experts,
    i am getting the below error when i was giving * (Star) to view all the items in DB
    [Microsoft][SQL Server Native Client 11.0][SQL Server]The text, ntext, and image data types cannot be compared or sorted, except when using IS NULL or LIKE operator.  'Items' (OITM) (OITM)
    As i was searching individually it is working fine
    can any one help me how to find this..
    Regards,
    Meghanath.S

    Dear Nithi Anandham,
    i am not having any query while finding all the items in item master data i am giving find mode and in item code i was trying to type *(Star) and enter while typing enter the above issue i was facing..
    Regards,
    Meghanath

  • Drive Redirection virtual channel hangs when copying a file from server to client over RDP 8.1

    Problem Summary:
    A UTF-8 without BOM Web RoE XML file output from a line of business application will not drag and drop copy nor copy/paste from a Server 2012 R2 RD Session Host running RD Gateway to a Windows 7 Remote Desktop client over an RDP 8.1 connection and the Drive
    Redirection virtual channel hangs.  The same issue affects a test client/server with only Remote Desktop enabled on the server.
    Other files copy with no issue.  See below for more info.
    Environment:
    Server 2012 R2 Standard v6.3.9600 Build 9600
    the production server runs RDS Session Host and RD Gateway roles (on the same server).  BUT,
    the issue can be reproduced on a test machine running this OS with simply Remote Desktop enabled for Remote Administration
    Windows 7 Pro w SP1v6.1.7601 SP1 Build 7601 running updates to support RDP 8.1
    More Information:
    -the file is a UTF-8 w/o BOM (Byte Order Marker) file containing XML data and has a .BLK extension.  It is a Web Record of Employment (RoE) data file exported from the Maestro accounting application.
    -the XML file that does not copy does successfully validate against CRA's validation XML Schema for Web RoE files
    -Video redirection is NOT AFFECTED and continues to work
    -the Drive Redirection virtual channel can be re-established by disconnecting/reconnecting
    -when the copy fails, a file is created on the client and is a similar size to the original.  However, the contents are incomplete.  The file appears blank but CTRL-A shows whitespace
    -we can copy the contents into a file created with Notepad and then that file, which used to copy, will then NOT copy
    -the issue affects another Server 2012 R2 test installation, not just the production server
    -it also affects other client Win7 Pro systems against affected server
    -the issue is uni-directional i.e. copy fails server to client but succeeds client to server
    -I don't notice any event log entries at the time I attempt to copy the file.
    What DOES WORK
    -downgrading to RDP 7.1 on the client WORKS
    -modifying the file > 2 characters -- either changing existing characters or adding characters (CRLFs) WORKS
    -compressing the file WORKS e.g. to a ZIP file
    -copying OTHER files of smaller, same, and larger sizes WORKS
    What DOES NOT WORK?
    -changing the name and/or extension does not work
    -copying and pasting affected content into a text file that used to have different content and did copy before, then does not work
    -Disabling SMB3 and SMB2 does not work
    -modifying TCP auto-tuning does not work
    -disabling WinFW on both client and server does not work
    As noted above, if I modify the affected file to sanitize it's contents, it will work, so it's not much help.  I'm going to try to get a sample file exported that I can upload since I can't give you the original.
    Your help is greatly appreciated!
    Thanks.
    Kevin

    Hi Dharmesh,
    Thanks for your reply!
    The issue does seem to affect multiple users.  I'm not fully clear on whether it's multiple users and the same employee's file, but I suspect so.
    The issue happens with a specific XML file and I've since determined that it seems to affect the exported RoE XML file for one employee (record?) in the software.  Other employees appear to work.
    The biggest issue is that there's limited support from the vendor in this scenario.  Their app is supported on 2012 R2 RDS.
    What I can't quite wrap my head around are
    why does it work in RDP 7.1 but not 8.1?  What differences between the two for drive redirection would have it work in 7.1 and not 8.1?
    when I examine the affected file, it really doesn't appear any different than one that works.  I used Notepad++ and it shows the encoding as the same and there doesn't appear to be any invalid characters in the affected file.  I wondered
    if there was some string of characters that was being misinterpreted by RDP or some other operation and blocked somehow but besides having disabled AV and firewall software on both ends, I'm not sure what else I could change to test that further
    Since it seems to affect only the one employee's XML file AND since modifying that file to change details in order to post it online would then make that file able to be copied, it seems I won't be able to post a sample.  Too bad.
    Kevin

  • Try to use one comupter as both server and client

    Hello, everyone, I am just trying to use my own computer as both server and client to test some codes about networking. For example, use the sample code in java tutorial which is used to test Echo server(code is listed below). Is there anything I have to do to set my computer, such as set my hostname or something like that?
    I am a pure newbie. And the purpose of this question is to test some code including socket on one PC without connect to internet.
    I have tried to change the name "taranis" in the following code to the computer name of my own PC, but it doesn't work, and said: Couldn't get I/O for the connection to: (my computer name).
    import java.io.*;
    import java.net.*;
    public class EchoClient {
    public static void main(String[] args) throws IOException {
    Socket echoSocket = null;
    PrintWriter out = null;
    BufferedReader in = null;
    try {
    echoSocket = new Socket("taranis", 7);
    out = new PrintWriter(echoSocket.getOutputStream(), true);
    in = new BufferedReader(new InputStreamReader(
    echoSocket.getInputStream()));
    } catch (UnknownHostException e) {
    System.err.println("Don't know about host: taranis.");
    System.exit(1);
    } catch (IOException e) {
    System.err.println("Couldn't get I/O for "
    + "the connection to: taranis.");
    System.exit(1);
         BufferedReader stdIn = new BufferedReader(
    new InputStreamReader(System.in));
         String userInput;
         while ((userInput = stdIn.readLine()) != null) {
         out.println(userInput);
         System.out.println("echo: " + in.readLine());
         out.close();
         in.close();
         stdIn.close();
         echoSocket.close();

    Did you write the EchoServer and start it on your
    machine, listening on port 7?
    You can have the client and server running on the same
    machine or different machines, but they have to be
    separate pieces of software.
    Write a separate EchoServer class that starts up and
    listens on that port. Then start the EchoClient and
    make the connection.
    %yeah, I didn't wrote the EchoServer class. But I thought it is automaticly included and therefore has run once I start my computer.
    If I write a EchoServer class, then how should I set the host name of the EchoClient, just simply change "taranis" to my computer name (change "echoSocket = new Socket("taranis", 7);" to echoSocket = new Socket("(my comptuer name)", 7);"?

  • My Macbook was hacked by somebody right after activating downloaded VLC player. I couldn't control my machine. Every thing was messed up! Finally after reboot I realized that even my administration password was changed. Stupid hint I was able to reed: Wha

    My Macbook was hacked by somebody right after activating downloaded VLC player.
    I couldn’t control my machine. Every thing was messed up! Finally after reboot I realized that even my administration password was changed. Stupid hint I was able to reed: What located in box above low case ? I used my friends computer and founded hot to fix my problem using Unix commands to reboot in a single user mode. I founded a lot of different solutions which had prity the same beginnings but very complicated continuation, which, I understood will force me to cach during restoration anuther crap – time bomb in my mac! Finaly I did restor. somehow. But still feel somebodyies presents. Safary messed up – I will send you a log Itunes – messed up. Speaker in a top menu – grayed, and I can’t control my volume. But the most triky thing – bouth my Apple keybords – internal and mostly bluetouth external also working and typing wired! I am sorry for my spelling, because I cant check spell for Mac’s Word (in Microsoft it was F7) I have also several attacks from my neighbors by community I know their names, because they are somethere very close to me – I can see them throuth FI-FI connection. They often kick-me out from my place and started to use my resaurces. And also Mackeeper make me a hard time!
    In Microsoft times u just reinstalled computer – clean installetion from corporate licensed disk. But now I am a beginner in MAC – I love it! But a lot of new and triky – at this way
    Fore example – my goal – to do fool Macbook backup at external USB drive using boot srartup option and make my life yaser in case of crash. But now, I don’t know if I can trust recommended program  Carbon copy cloner – Ms. Bombich?
    I am very sorry for my spelling, because I feel somebodies presents, who playin with me.
    Final question Do I need some antivirus Mac compatable which is update paches, service packs? How to map defolt documents folder not to a local, but to external USB?
    Esquse me for a lot of questions, but I am beginner in MAC, and I LOVE it!
    PS. Good news. Looks like Safari came back! Somebody, probably allredy helping!
    But my interface qute different from original – so something still wrong!

    Didn't really read much at all of your post. Much, much too long, irrelevant details and & no paragraphs.
    Can't use time machine due to corruptness
    Post over here -> Mac OS X v10.6 - Snow Leopard forum
    About my macbook and apple ID how can I upgrade my Macbook from 10.6.3 to 10.6.8 with out all the permissions being changed and corrupt??
    Same as above. Post in the correct forum.
    Need to gain access to my apple Id that would be a great start
    -> http://support.apple.com/kb/HT5625

Maybe you are looking for